Z Height too high?

#1

Hi, I’m trying to fine tune my Moai and now I’m finding an issue with the Z height on a print test of the Calibration Cube (~20.56mm on Z axis). I’ve followed all the calibration guides from advanced leveling to X and Y Size adjustments for dimensional accuracy. My question is how I can adjust or calibrate for the Z height discrepancy? I’ve read through a lot of the topics but couldn’t find anything talking about Z height accuracy being too high. Thanks in advance and here is some background data:

Corner Calibration Measurements (most of the time slightly skew but attributing to being printed directly to plate?):
A - 10.80 mm
B - 10.84 mm
C - 10.80 mm
D - 10.79 mm

20mm Calibration Cube printed at Center with supports generated from XYZ SW (medium contact point/density):
X - 20.06 mm
Y - 20.02 mm
Z - 20.56 mm

Moai Settings:
FW - V1.15
Resolution - Moai 50um profile in Cura Moai Edition
Resin - Peopoly Clear
X Size - 922
Y Size - 922
X deviation - 100
Y deviation - 100
Smooth - 50
Z moto speed - 8
PM moto speed - 20
Laser Power - 58
XY Speed Set - 4
Z Reset Position - 1877
PM Reset Position - 40
Z Follows - 40

1 Like

#2

z is rarely out of accuracy unless there are some changes to curing property or the model is scalled in someway. can you share room temperature, print profile used.

btw, we noticed you have none standard x/y size. Most user who did
Advance Moai calibration guide:

rarely needs that much of adjustments on x/y size

0 Likes

#3

Hi, the room temperature is ~65F . I did not scale the model and used the 20mm Resin Saving Calibration Cube referenced in the forums, only added auto supports with XYZ Software. Without the X/Y Size adjustment, the X and Y cube measurement is ~ 19.56mm, therefore I added 22 to X/Y size as I read each step is ~0.02mm adjustment with V1.15 FW (Z measurement still about the same at ~20.6mm). Is it possible hardware defect somewhere? Thanks.

0 Likes

#4

Hi!

Your room temp seems too low - the resin should at least be 20c and preferably 25c, which means that the room temp should at least be 25c and even then it takes a while before the resin is warm enough to give the best results.

I do not know how much the fluctuation in room/resin temp affects the dimensions (xyz), but you could try to warm the resin to 25c and print at that temp.

The following link may be of interest:

0 Likes

#5

I tried again in a room temperature of ~84F . Same thing. The Z-axis height difference is consistent to the same measurement around 20.50mm - 20.56mm. When I print larger object, the discrepancy is even larger @ 1mm or greater (consistent off z measurement on the same part printed multiple times). The print profile used is the default 50um Moai in Cura. This is a huge concern for me as I’m trying to design parts and the difference is too great.

I also did the advance Moai Calibration guide again and found that I needed to still change the X and Y Size, but dialed it down a little to X Size - 916 and Y Size -919.

If this rarely happens, as Peopoly mentions, what is the usual cause of it? Is it possible some piece of hardware is defective? Please help ASAP as I have tried troubleshooting with this printer for ~3 weeks now. Thanks.

0 Likes

#6

Here is a test file you print directly on the built platform. The file itself is 31mm tall but we want to know the measurement from the top of the post to the base and that should be 30mm. So the overall length will be short depending on the compression you have for your leveling.

Have you printed the ring test file with the laser at 58? If I remember right 58 might be on the high side.

Do you mean the post are leaning? If you post some pictures it might help.

0 Likes

#7

Still doesn’t look like a satisfactory answer has been reached here. What is even the point of printing the 30mm test if there is no way to ajust afterward?

I am having the same problem where the taller the object, the more the height discrepancy appears (more than 1mm at 120mm height in Z)

I read somewhere that the Z axis lead screw is not the pitch that the firmware expects which can cause increased z height distortion the taller the object gets.

Unfortunately, the firmware does not allow the ajustment of z steps per mm so the only way to get accurate z dimensions is to squish your model an undetermined amount.

@peopoly some of us are really trying to use this machine for engineering purposes, but we need your support. PLEASE HELP!

0 Likes

#8

Same problem in one of my olders posts. No clear answer from peopoly too… Strange, isnt it?..

0 Likes

#9

I decided to give up and move on. If you need dimensional accuracy for your application, I could not recommend this printer as it seems like there are too many variables that can put it out of true. Actually it’s not even close since being off by ~1mm is one thing, but if the print gets even slightly skewed, things don’t fit together and it’s useless. I think FDM style printer could produce more dimensionally accurate models. I feel like it may be some known HW issue for some, but get the run around to re-calibrate and make sure the stars are aligned while resin temp is 25.2632 degrees C . I’ve spent months trying to remedy/accommodate for this issue with little to no improvement.

1 Like

#10

I am having issues with Z axis accuracy as well. After calibrating Asura I was able to achieve ± .05mm accuracy on all measured dimensions of the calibration cross in both X and Y axis. All fasteners have been rechecked, and machine level has also been rechecked.
This part was designed in Fusion 360, exported as .stl with high detail, imported into Asura, centered on build plate, Moai130 40µ layer height profile was selected, exported, and then printed with the provided settings below.


As you can see from the picture above the Dia. I printed 2 parts at these setting with the following dimensions.
CAD/STL file Dia. 40.2mm Thickness 3.75mm
Part 1: Dia. 39.77mm Thickness 3.5mm
Part 2: Dia. 39.80mm Thickness 5.52mm
Deviation% Dia. 0.995% Thickness 6.67%

Firmware settings are as follows.
X Size 900
Y Size 900
X Deviation 100
Y Deviation 100
Smooth 50
Z Motor Speed 2
PM Motor Speed 15

Advanced Setting
Laser Power 58
XY Speed Set 4
Z Reset Position 1877
PM Reset Position 10
Z Follows 2
CompensateX 100
CompensateY 200
Z Initial Speed 2
PM Initial Speed 10

Print Ambient Temp: 76.8F (24.89C)
Resin: Peopoly Model Resin (Black)
Fasteners: All triple check - none loose
4 Post level: A10.69mm B10.68mm C10.70mm D10.68
Asura XY Calibration: All measurements ± 0.05mm

Asura XY Calibration model Deviation %
Average XY 1.3%
Average Z (over 3 prints) 13.5%
Model Z height is 4mm, prints came out between 3.46mm, and 3.51mm.

@peopoly If you are getting accurate Z axis dimensions please let us know what is going on here. Is it possible to add Z axis control perimeters to the firmware? Also there should really be a Z Rapid Height (point offset vertically from vat surface), and Z Rapid Speed setting in addition to the current Z Motor Speed; this would allow the build plate to quickly move to a point above the Vat then slowly lower into the resin. I have noticed air bubbles form using the default Z Motor Speed as the build plate lowers into the resin, and have seen small bubble marks on parts where they contact the build plate surface.

0 Likes

#11

Are you using supports to raise the model from build plate (3mm)? If you print directly on the build plate you will not get correct z height because the first layers are compressed.

0 Likes

#12

@Whazaa In short; no. This is something I was theorizing while examining the prints, and was planning on doing next. I can see why so many prints I have seen up until now are printed on supports. Basically any print that I want dimensional accuracy on will have to be printed with supports correct? Admittedly I am new to SLA printing and still learning. Unfortunately documentation seems to be an issue with the Peopoly ecosystem; with information incomplete or spread out in many locations. If you have done accuracy test would you mind sharing your results?

0 Likes

#13

The first layers are compressed for better adhesion to the build plate. So your prints will dimensionally end up just fine after you put them on supports.

Super accuracy is not the main thing for me - but if that is your main goal you should follow the calibration guide on this page

http://wiki.peopoly.net/doku.php?id=moai:asura

0 Likes

#14

Yeah I went though making sure Asura was calibrated. While the print was on the build plate still I down to a max deviation of .04mm on any of the points which is fantastic. Though my custom made part wasn’t that good in the XY axis (deviation of .43mm - .40mm). I will start using supports from now on, and see what I can come up with. Thanks for the heads up; hope putting the model on supports will give the accuracy I need. Planning on getting an Arduino controlled heating element set up for more control over temperature in the coming week or so as well.

1 Like

#15

the Asura adjusts for XY distortions but not Z.
For any bottom up resin printers (basically everyone under 5000 USD), the first few layers are compressed into the plate to achieve good adhesion. The result is total z-axis height is affected if you are printing straight off the plate. You can raise it with a support but if that is not an option, then your leveling has to be as close to 11mm as possible. The extra exposure time for first few layers also expand the resin and thus that will affect accuracy too. So the best solution is still raise the print up by at least 2-3mm

0 Likes

#16

What would you suggest if the prints look great, except the area around the supports are always build up a little more, or saggy?

For example, I am printing a lot of rings and every single one of them is distorted at the bottom of the shank if it were straight up. Even the Resin saver cube does this.

EVERYTHING does this.

Any ideas?

0 Likes

#17

Have you got the heater? What resin are you using?

1 Like

#18

Yes, I have the gear heater. I have tried
Photocentric castable, waxcast, peopoly neon, nextdent casting, bluecast

0 Likes

#19

Initially you could try upping laser power.

If not, you should start a new thread with pictures so support can help easier.

1 Like