Z Axis stepping motor not working while printing


#1

I have purchased the Peopoly MOAI about a year ago as a kit and assembled it myself with success and without any problems.
Since then i have made a lot of prints with about 85% success mostly for jewelry models for silicon molds or for wax casting.
Today i tried to print another model and something unexpected happened.
While i open the printer the Z Axis motor is working as it should but when i try to print and after every layer it does not work and it does not go up so the next layer is printed at the same place and the next and the next…
At the end of the printing the Z Axis again goes up as it should again.
I tried a lot of models and settings changes on the printer but nothing is working, do you have any idea what i should do or what component is controlling the Z Axis motor, it is like it does not take a command to move up when every initial layer is printing and also there is no sound on the motor at all during this process.
Thank you for your time and i hope you can help me with this issue because the printer is now unusable!


#2

does it go up and down when you power on and off the unit?


#3

Did you recently change computers? Or, specifically, from PC to iOS?

After that: do the pre-sliced files from Peopoly print properly?


#4

It does go up and down when i power on the unit and when i try to print but only then.
I did not change anything to my setup of computer and software etc except that installed the easy level build plate nothing else.


#5

Is your computer a Windows box or a MacOS box? There is an issue with MacOS slicers improperly formatting the g-code. I would look at the g-code to confirm that the line returns, etc. are in the right place. What are you using for slicing?

The issue is seems to be occurring during g-code interpretation. If Peopoly’s pre-sliced models display the same issue, then it may be hardware related. Check the SD-card reader for bad pins and change SD-cards, if you haven’t already. You can try reformatting your current card, but I prefer a full reset. If this reveals nothing, then I’d start looking at the main board. Have you updated the firmware recently?


#6

My slicer is Cura with latest MOAI profiles on windows 10 computer.
I always format the sd card before copying the gcode files because i have “paranormal” problems with them in the past and since i formated them had no issues!
I also used a new sd card and the original that came with the printer with no result and i have the latest firmware too on my printer.
I have not checked the gcode but i used also gcode files that i have already printed in the past with success so i do not think this is the problem.
I am afraid that it will be a problem with main board or some other board but it will be great if i had feedback by PEOPOLY…


#7

if the z motor still goes up after the print, that means it’s still working
the problem is either the firmware or the slicer
what’s your firmware, and what slicer you used?


#8

I am using Cura 3.5.1 slicer on a windows 10 pc and the firmware i have is 1.18.
The only change before this problem was the installation of a new easy leveling building plate and nothing else.
Before that i was printing fine , i forgot to mention that there was a suction effect between the easy leveling building plate and the PDMS vat for just a second after i install it and resetting the Z-reset function but only for a second and the building plate returned to its default position immediately after that.
I also tried to print gcode that i already printed successfully before so i do not thing it is the slicer.
Should i try to re apply the firmware that was working before?


#9

print the ring see if that works but before you do, use the SD card format tool on the wiki and format with overwrite option. then recreate the gcode folder and put the ring gcode in there and see what happens


#10

I already have done this but thank you!
I also formatted the sd cards in linux computer with no result.
For best result i only have one gcode file in the gcode folder too.
It is very strange to me that without changing anything special in the procedure that was working for more than a year suddenly i have this problem.
My printer is unusable and i am staring to have serious problem with my work and now paying others to build my models and also have delays because of this.
I do not know how the firmware works but it seams to me that small steps on the z-axis motor work differently than the on / of function that “parks” the building plate to the top or maybe there are different voltages included to both functions and the voltage for small steps is not getting thru , just guessing…


#11

did you do the test print and the leveling print after that?

how is the result on the ring?


#12

I could not do the test print or anything else because of the problem i am describing, after the installation of the easy leveling building plate the z-axis had this problem but i cannot imagine how this would affect it!
When i said i already done that i meant “use the SD card format tool on the wiki and format with overwrite option. then recreate the gcode folder and put the ring gcode in there and see what happens”


#13

that is weird result.

  1. does the problem persist if you switch back to the class build plate?
  2. can you slice with Asura instead? because the software has locked in the most stable (not the latest) curaengine with matching profile?
  3. Can you reflash firmware 1.18? and set
    ez-level plate does not need setting changes, only fep vat needs updated settings

#14

It is indeed weird!
I have not moved back to the old build plate but i have made several tests without vat and building plate and the z-axis is not moving while “printing”.
I will have to check with Asura because i was not using this software and get back to you!
I will also try to reflash the firmware, this was something i was also thinking!


#15

Finally i have resolved this issue!
I have reflashed the firmware and it prints again!
This was very weird…
I have a new problem now but with the easy leveling build table, i can not print anything on it.
I can print normally with the old building table but not with the easy leveling one.
The prints stay on vat and i have used several settings but nothing!
I have followed the easy leveling building table installation instructions to the letter but i can not print anything on it.
Does someone had similar problem with it, is there any solution?


#16

there are settings in firmware that will slow down pm motor significantly. Thanks for sharing.

Have you relevel when switching plate? The ez-plate is actually more sticky than the old plate as it is made of softer aluminum


#17

I had the newest firmware on the printer and i reflashed with the same one, this was very strange to me!

I have followed the instructions for the installation of the easy level plate but nothing, all my prints stick to the vat…

I have also changed the Z Reset Position from 1878 to 1877 but nothing again, i also used a special sticking solution from bluecast that coats the building plate for prints to stick more but have no result.
The strange thing is that when i use the old building plate ( not the easy leveling one ) without any change to the leveling it prints normally without any problem and all the models stay on plate.


#18

the z-reset is how much the plate moves down, so the 1878 would be closer to the vat than 1877. The simplest way to make print stick is to keep increasing z-reset but that usually lead to less optimal resin. The instruction is 1877 to set ez-plate and then increase to 1878 if not sticking. You can also try 1879 just to be on the conservative side.