X, Y co-ordinates and X scale moving

After several months of problem-free use I stopped using my Moai for a few weeks. The first and second prints I ran after that were complete disasters - the X and Y co-ordinates had drifted about 1cm each away from the centre of the FEP tray and the X scale had roughly doubled - so the objects were skewed and stretched and overhung the edges so were missing parts.
I ran the calibration gcodes, for the cross-hairs and circle test, dismantled the printer sides and recalibrated both X and Y galvos to be centred again, and adjusted the X scale potentiometer on the X galvo board to make a perfect circle.
Then I ran another print overnight. That too was a disaster. I found the following morning that the X and Y coordinates had moved again, by a small amount, during the print and that the X scale was once again stretching to make the test circle shape into an oval. I don’t understand how this is possible unless the potentiometer resistance is changing by itself?
I have checked all of the connections between the boards and the galvos, unplugged and reconnected them to be sure it is not a bad connection.
I conclude that the printer has a more serious fault somewhere.

how long since you buy the Moai? and from where?
try to re-calibrate the galvo, after it’s done try putting a tape on the potential meter. I am expecting that the potential meter is moved from the machine’s vibration

Purchased in December last year (2019), from iMakr in London, and arrived April 2020, in use from late April until early August without problem. It is on a stable base, with no external source of vibration, and not been bumped. It has a plastic cover over it when not in use, to keep dust out.
I have recalibrated the galvos again, tightening them as far as I dare without bending the hex key, and adjusted the X pot - by about 1/2 a turn - until it passed the cross-hair and circle tests again.
I am doing small prints to test it by stages. So far so good. If it moves again I will add tape to the pot and revisit. I understand this can be a connection issue so maybe extra resistance from some other source?


I recalibrated my Moai and put glue and tape over the galvo potentiometer screw head. This has not stopped the X scale from drifting. Now I have the additional problem that larger prints do not stick to the print head, while small ones are fine. They peel off and stick to the FEP tray bottom after every few layers. I have tried re-levelling the print head, making sure the screw is very tight and increasing the Z Reset Position, several times from 1815 to 1818 but still get that problem. Meanwhile my X scale is gradually drifing away (always increase) from true. Looks like faulty parts to me. I am concerned at getting no reply from support in this forum.

I believe i’ve replied your email, Andrew Hicks?
if it’s true, we will continue with email from now
in the future, if you have any problem. Please post it and troubleshoot in 1 site, either forum or facebook or email. So that the information is more manageable

Yes you have replied by email, thank you, and I have already responded with a question about the warranty on replacement parts. I appreciate your support very much. If the response is prompt then I will only go through one channel and am very happy. If I post or email and get no response after a few days then I will try another route. Sometimes I post or email and get no response at all, in which case I am not so happy. Is that unreasonable?

it would be spam emails in that case :slight_smile:
even if you want to spam, just reply to your own email thread. Individual emails would just make yours harder to track down the original. Like the picture emails, reply to your own emails instead of having 3 separate ones