Wiring Diagrams


#1

About a year ago Paradoxical Cat asked about clear wiring diagrams with wire colors.

The user points out about the pictures in the manual.

In my manual print it is extremely difficult to read the wiring information from the images.

So I would like to reiterate. Has this been resolved?

I am posting as a self contained thread in Hardware as I believe that is the proper place for this particular issue, as I am uncertain who will see my reply to aforementioned user if any as the former thread is more than a year old as I could understand.

I desperately need proper wiring diagrams to be able to verify why only galvo driver lights come on when I power on the printer in addition to the blue power ring.

It might be a power distribution issue, or it could be burned out boards or something else.

Someone knowing the boards should be able to create a super simple wiring diagram outlining the boards and connectors in less than an hour or two using a free off the shelf electronics diagram software and then save the wiring diagram.

My vendor is hundreds of kilometers away in another country, so I need to be able to properly verify what the issue is and in detail describe potential problems with the kit to them in order for me to potentially having replacement parts sent etc.

I tried clicking the links in the google docs that I think supposedly should lead to clear / bigger images but to no avail.

Hoping someone sees this and has an answer, hopefully some proper wiring diagrams.


#2

Better documentation would be great! I fully agree and support your request.

In the meantime, I took advantage of the silkscreen markings on the power supply circuit board that are next to each connector. They indicate the function of each pin.


#3

Thanks, I am planning on backtracing everything, will be spending the weekend looking into the matter, just surprised a printer costing 1000+ EUR does not have such basic data clearly visualized in the building manual.


#4

Sorry for the issue that you have, with the current wiring we have tags on the wire and pictures to show where it should be plugged on the guide. But it seem here that user still have trouble with this.
How would you feel about a color coded circuit? Would that make it easier for the users?
Let me know what you think


#5

users mostly use these 2 diagrams:
https://drive.google.com/open?id=0Bzke6lBHG_z5VWd2ZG1yQ182WE0
https://drive.google.com/open?id=0Bzke6lBHG_z5a1Ntek5tMUozNmM

both diagrams have labels that correspond to the included cables and should load up pretty clearly

if you need a helping hand, take a picture of your wires and card (keep all of them in a single pic) so we could take a quick look.


#6

Will try to access those links when I am at at a computer and near the printer to do further verification, just had problems accessing links from the ‘manual’, maybe it will work better this way, can also inform that the printer currently gets as far as past the boot but it is incredibly sluggish in responding to commands and for example does not recognize the directory on the included SD card even though I can see it is there and has files on it. It is running 1.18 firmware


#7

Color codes is a help, but keep in mind some people are color blind too, so it can’t be a stand alone thing, you need above all to keep writing on boards, and then include a wiring diagram and not photos alone, the photos can be an assist as they are now but include a clutter free simplistic wiring diagram. As a help to myself I have drawn one and color coded pins according to what I see on my own pictures, just hard to take pictures once everything is assembled


#8

OK I could see those diagrams clearly and the MOAI was wired correctly, still think a proper wiring diagram would be of use rather than looking at pictures. As I mentioned earlier if waiting a minute and a half or so the MOAI gets through the “boot sequence” but is responding incredibly sluggish to input - (it is very slow when turning knob selecting “print” in order to be able to do the initial calibration test etc. it hangs for maybe 30-60 seconds before stating “select folder” but the MOAI does not see anything on the SD card, I have tried creating different folders capital letters, not CAPITAL letters etc. on the SD card, tried renaming the existing gcode folder and then creating a new gcode folder both CAPTIAL and no capital letters to no avail - trying to turn the knob when asked to select does not do anything either, if trying to push to select - After a while the MOAI simply says NO folder… So stuck without being able to test calibrate etc.

I also note the interesting behavior that you need to turn knob two notches before the MOAI reacts to the knob.

Furthermore I have no way of knowing if the control card of the MOAI is actually seeing the SD card or if it is the control card not being able to communicate with the reader itself.

Suggestions on how to proceed ?


#9

I can see the SD card reader mentioned as an issue here are a few shots of the reader pins and it does seem like the first inner/lower pin does not have much if any contact with the print

any suggestions?


#10

The mobile is not a perfect match for taking close ups, sorry


#11

From these pictures it is obvious that you need a new SD card reader board. Some of the inner row pins are lose and have been pushed out of place.

If you have a finetipped soldering iron or a desoldering heat gun you could try to resolder the joints.


#12

And now the MOAI is just dead - Not going through the boot sequence where it was earlier… simply blue ring lit on power button, and green lights on the Galvo X,Y driver controllers…? Have to say I am not entirely happy, this is a 1000 USD+ piece of equipment I have people lined up for prints… This experience is looking likely to be going to costing me dearly both financially as well as in reputation.


#13

The problem with the SD card reader module comes in my opinion from the fact that the pins are under stress when the board is held down by the screws. You need to shim the bracket holding the board so that it sits flush and not bend.

I hope you can fix this issue or get a replacement reader board from your supplier.


#14

I can see what you are saying about spacing, tried a microscopic massage and now it gets back to the menu at least, I have sent images to vendor also and still unable to get any folder readings from the SD vard despite the fact that I can read the folders on other devices (this is the card originally delivered with the printer with the original files from Peopoly on)


#15

The SD card compatibility is also a djungle for some users. My Peopoly card is good for gcode transfers from my PC but I can not do a software upgrade with it. For this s use a designated cheap unbranded SD card. Perhaps you could try to format a cheap SD card with the suggested formatting tool and see if the gcode folder pops up…


#16

I get where you are going with the formatting thing - But the card is stock Peopoly delivered with printer - There should be no such issues, and clearly the SD connection to the MOAI board has design flaws in that the screws as pointed out in the thread above. These are not just kinks that can be expected, this is a regular purchase done through a re-seller and the re-seller will be responsible in most cases in Europe to provide working parts under warranty. Have reached out to re-seller regarding the issues I am experiencing, but will naturally look into options while awaiting.


#17

Here is what I imagine when I mention a wiring diagram - Notice this is meant as an example!

no guarantees as to the correctness or color coding. However this should be as easy for you to produce, as simply saving the silk mask files for the PCB production that you already must have and adding a few lines and colors to the plugs etc…


#18

Tried different SD card formatted with MOAI provided SD formatting program - copied gcode to directory called gcode… It boots faster and interestingly enough but when selecting print MOAI stille reports no directory/no gcode file - So I suspect the reader must be malfunctioning or the controller card…


#19

I assume you have only a folder named gcode in root on the SD card. I save all sliced gcode files to the desktop before I transfer them to the root on the SD card. After this I open up the root on the card and drag/drop the file into the gcode folder. This has worked for me but if your printer doesn’t see any folders then I suspect a faulty SD card reader board.


#20

Did you resolder the connections on the card reader board?

Also make sure that your file name is less than 25 characters.