Weird striping effect


I tried KISS but --as you say-- it really does too much behind the scene. IceSL on the other hand is very simple and it can use the GPU for slicing (that could be a good thing I guess). Also you can output the code in any way you want. For example I’ve added the layer count and 3 slow layers directly from LUA. Have a look, I’m testing this right now:

G0 Z0.100
G0 F3000 X69.625 Y68.005
G1 F300 X69.840 Y67.520 E1
G1 X70.335 Y67.330 E1
G1 X70.730 Y67.370 E1
G1 X71.040 Y67.345 E1
G1 X71.235 Y67.315 E1
G1 X71.695 Y67.160 E1
G1 X71.890 Y67.065 E1
G1 X72.025 Y66.980 E1
G1 X72.310 Y66.765 E1
G1 X72.465 Y66.620 E1
G1 X72.725 Y66.290 E1

I haven’t tested that last profile, if everything works I’ll post the config!

PS: so far it looks pretty stable, but if you slice via GPU you need a pretty powerful card


So. Even more tests. I think I start to understand what is happening and it’s neither easy to explain nor to solve.

First of all here’s my latest test, not perfect but incredibly better than the initial tests. This one is done with Cura 3.4.1.

I can confirm that the culprit is 100% the slicer, not so much rounding errors or at least not entirely. All my efforts so far were targeted at improving the slicer resolution, but it turned out that increasing the resolution you also increase the defects and anomalies. Remember that STL is an approximation by itself. So you lower the quality when you export to STL, lower it again when you slice and lower it once more when you create the toolpath.

So, what’s the solution? Make the slicer resolution as low as possible (I know, it’s weird). You should set it at the minimum resolution required by your 3d model. For geometric 3d models it should always be set pretty low. Remember, I’m talking about slicer resolution (the way the model is sliced) not layer height.

To do so unfortunately you can’t use @peopoly’s version of cura. They set the slicer snapDistance too low. It is good to keep all the tiny details but it also emphasizes all slicer issues.

The solution is not easy as each 3d model requires a different configuration and you need some trial and error before you can remove all (or most of) the surface problems. But basically you have to tinker with various options in Cura and carefully analyze the output.

The best would be probably to have a user editable option for the snapDistance. I don’t want to bore you to death, hopefully I’ll talk to Mark about this… but now I’d really like to know how Form2 software works.


thanks for this feedback. With 3.4 in the wing, we may have to make modifications before releasing.


@matt3o, nice work. What you’re talking about is similar to having a small CNC cutting tool “bounce” on a render mesh as tool paths are being generated. The CAM software I use creates a render mesh for the express purpose of creating the tool path. I can control the parameters of the rendered mesh and the tolerances of the tool path generator. While there are some good universal settings, you’re correct in saying every part is different. Once I figured out what worked best for different types of geometry the only variables left were the tolerances of the hardware. If those are good your parts look great and they’re dimensionally accurate.

Since you started this thread I’ve been thinking this sounds like an issue with the quality of the mesh but you’ve discovered more. You’re saying if the resolution of the slicer is low, it will be less sensitive to irregularities in the mesh but you can lose detail. A denser mesh is usually better to insure well defined detail but then you expose yourself to the tolerances of the slicer and in all cases the tolerance stack up of the hardware. The 2 are not always working well with each other. It probably explains why some parts look incredibly good while others are less to varying degrees. The incredibly good-looking surfaces are most likely a product of having the mesh geometry hit the sweet spot of the slicing software.



the difference with a CNC mill is that here we have one more translation, which is the slicer. That is a very nasty beast. Basically lowering the slicer resolution you also reduce the surface jerkiness and the possibility that the toolpath generator catches those irregularities.

One more thing, the supports really mess with the slicer! As of now I haven’t seen a support generator that builds them correctly (except PreForm maybe). Let’s hope in Asura3D.


I did some tests with my new profile in Cura and the difference totally blew me away! Have a look, on the left the old profile, on the right my new profile. Both tests are at 20um

The moai has a lot more potential than it is currently showing! The new profile will be hopefully available soon for everyone to use :slight_smile:

I also found what’s the problem with the glitches near the supports, that is not caused by the slicer but it’s the moai, I’ll talk to @peopoly about that, maybe we can do something about those too.


Oh wow! Give it to us please! :slight_smile:


That´s great news. Are there too many settings in Cura to adjust?
I´d really like to give it a shot, I´m re-printing my head and I´d like to see how it goes.


his changes is related to 3.x version. We will release some info on you can do this very soon.


Been following this for a while now. just had a couple questions

  1. does the effect change with feature aspect ratio? ( extrusion height vs diameter, cut depth vs diameter)
  2. shape of feature. ( more pronounced as round, what about square or hexagonal)


it’s not an easy problem to solve and many factors are in play. First of all how the 3d model has been created AND exported to STL. As of now cura-moai is configured to catch all the smallest surface features, that is not always what you want and sometimes it just makes the print look bad.

If you slice at 100um it is likely that you won’t notice any issue because the resolution is just not high enough to catch the defects. When you go at around 50um everything must play in concert. 3d model resolution, slicer resolution, rounding errors etc…

So sometimes some glitches can be “hidden” by modifying various options (rather randomly) like nozzle size or wall overlap. That is something I do not suggest to do, believe me you don’t want to do it… I already destroyed one VAT. Just wait for the new profiles that should be good enough for the majority of the 3d models. I’ll possibly post a tutorial about that as soon as the new version will be available.

Another completely different problem that causes some of the surface issues is I believe acceleration. Unfortunately resin cures at a specific laser power + laser speed. Since we can’t dynamically change the laser power the whole model should be printed at a constant speed. (mere speculation mode ON) I believe presently the moai is not configured to slow down enough to let the laser make very sharp corners (like all the times a support meets the surface of the model). That leads to errors in the toolpath.

TL;DR: @peopoly is working on it and I’m giving him all the support I can. Very soon I bet we’ll have a cura able to take advantage of the full moai potential.


Is there consideration of supporting laser power settings in gcode?


Same here! Yeah it sucks to work that but extra to get a smooth surface. I hope this problem is resolved soon .:confused:


Here is my striping issue.

Last picture actually has a crack near the end of the engine! Is it Bluecast resin or Cura?:thinking:

@peopoly please help!


do you have the set up picture in Cura? I believe someone answered this in FB as well?


Today I had an epiphany! Thanks to @peopoly who mentioned something about semi-cured resin in another thread I made one last test. Let’s start with a picture.

The little dots are where the supports touch the model. On the left each point has a stripe going down, on the right my new experiment, (almost) flawless.

This is what I think is happening. A very little bit of resin is trapped around the support near the model surface (but it could also happen with other features of the 3d model). The laser passing so close to these little resin “bubbles” starts to slightly cure them. At 0.05 layer height the laser has 10 layers to (semi-)cure the resin residue around a 0.5mm radius support.

To prove my theory I printed with a very low viscosity resin and upped the laser speed as much as possible (so less time to cure the bubbles). The result speaks by itself.

Bad news is that I don’t think you can completely solve this issue with the current vat, good news is that it’s totally feasible with the upcoming FET vat.

I still have to do more tests but basically I believe you have to actually raise the speed as much as possible until you don’t see these glitches anymore, to do so you need to also raise the laser power which we all know is not good for the PDMS layer (so don’t do it :P).

The best thing you can do right now is to reduce the viscosity increasing the resin temperature (possibly well over the 25°C and closer to 30°C). More tests would be required to find a better speed/laser power ratio but with the new FET vat a new world of resins opens up, so…

I could write an essay about this issue by now :confused:


What do you think is the best setting for the pepoly grey resin?
How fast i have to go with what laserpower?


It would be good to see the same model in terms of position, orientation, supports etc printed with the less viscous resin and original slower speed and laser power as in the black model.


you mean a full size picture of the red model? The black and the red are the same model, printed exactly the same position/orientation, just with different resin, speed and laser power.


I meant that you changed several things between the red and black version so the be sure that the reason the stripes went away was the speed and not just the red resin, you really need to print with the same speeds and laser power as in the black version to see that the stripes come back using the red resin.