Still can't update my firmware

It has been a month. I’m trying to update my firmware from 1.14 to 1.15. I tried many different types of sd cards. None of them work for me. After 60 secs the screen turns on and the firmware is still 1.14. I put all 3 files into the card and I’m using the sd formater. I’ve also tried to format my sd card with Windows.

Do you have any problems with gcode files?
Just to be sure what link are you using for the new firmware?
And just to cover all the bases are you using the following guide?

@Samuel_Yang

can you show a screenshot of the sd card content? and then a clip of upgrading (use google drive)
it may be something we can pick up quickly from looking through the process

these sd cards works well with gcode files. I’m sure the firmware is new. I downloaded it from the link you are sharing.
here is a video link: https://drive.google.com/open?id=1Imyxsc1xiwVHw57IvYD7KOV5tshLDh5o

Here are the screenshot and video:
image

try to downgrade to 1.13

with these files:
https://drive.google.com/open?id=0Bzke6lBHG_z5dnZJMW1qaTdBTWs

btw, can you show the file system of the sd card?

seems I can’t downgrade either. here are the screenshots
Capture2Capture3

how about this, stick with 1.14 and user 1.15 settings for now (expect x/y size will have to 360). We will follow up on this via email.

No problem , thanks.

Just to add my experience: I have two Kingston 4Gb cards in addition to the card that came with my printer. I could not use either of these cards to update my firmware, no matter what method I used to format them. This is on Windows 7. I ended up copying the firmware files to the Moai card, which worked just fine. I use these same two cards everyday for printing, but they would not work for the firmware. I’m keeping the Moai card exactly the way it came so that I can use it for future updates.

Sometimes it takes 1 minute to turn on the screen even there is no .bin file in the sd card. There may be some problem with the boards or the sd card reader. But I checked them and they all looks good.

How long does it take for the screen to turn on with no sd card in the printer? Mine takes less than 2 seconds.

We went through hundreds of card suppliers (even they also say Kingston/Sandisk) to find supplier that provide good but not always perfect sd card source. Sandisk just doesn’t work for upgrade and this is something that happens to other 3D printers as well. This card seems to work very well for several users:

My SD card reader is getting worse . I can’t even browse the Gcode files now. I need to reboot the machine many times to get it to work. I’ve checked the hardware but it looks okay.

Has the card reader been ruled out as the problem here? Look at picture 4 of the following post and see what yours looks like (the one in the picture is bad).

Mine looks good, the problem started since last month but it’s getting worse. Sometimes I could see the gcode files but most of time I couldn’t. I would upload a video later.

Here is the video and the screenshot of my sd card’s folder (https://drive.google.com/open?id=17ZabSOHHluYd9oecO-bGqWDOEgO6mC1n)

Here is the video and the screenshot of my sd card’s folder (https://drive.google.com/open?id=17ZabSOHHluYd9oecO-bGqWDOEgO6mC1n) It’s really annoying me cuz I couldn’t print anything now.

It might be helpful if you can get a good close up picture of the card reader pin on its own and the socket where it plugs into on the mainboard.

A problem like this could get progressively worse but the fact it wouldn’t do a firmware upgrade is strange. Maybe you have two different issues going on here.

Have you used the overwrite option in the SD Formatter program?

How many different SD cards have you tried?

We think it is likely to be the reader. email us at support