[Solved] Weak Laser After Less Than 20 Hours of Printing


#1

Unfortunately, less than a day after we fixed my previous issue, I seem to have another. The laser on my printer seems to be outputting far weaker than normal. The picture I attached above was my latest look at the laser. It’s taken in a pretty dark room, and the laser is noticeably dimmer than what I know it should be. It’s currently set to 63 in the picture.

I know that 63 is considered very high for laser power compared to the 58 for the peopoly standard clear resin that I am using, but I was having perfectly fine prints with it so I didn’t think much of it. (during my original testing, 58 did not cure the resin past the first layer to begin with) The ring test I originally did at 63 came up with all of the holes open, save for one which had uncured resin in it. (Didn’t do a good job washing it after printing).

However, now, at the same 63 laser power, I am not getting any curing at all out of the printer, save for a very thin, flimsy layer stuck to the build plate. I took a look at the bottom chamber to see if resin had dripped onto the protector glass, but it’s spotless. I even removed the protector glass when I took the above picture and it still looks that dim. My results are the same between the PDMS and FEP Vats (yes, I re-leveled when I switched). As far as I can tell, the bottom of both vats are clean. Has my laser seriously done itself in with less than 20 hours under the clock?

Edit: I was able to get a print out of the machine again, but I am now all the way up to laser power set to 79. Room is at roughly 18c, but there is a heater in the chamber, and I am letting it set for 30 minutes before starting a print.


#2

Check the connections and see if anything is loose. After that, support@peopoly.net.


#3

Make sure there is nothing on the galvo protection glass that might be impairing the laser beam.


#4

check the connections, re-plug the wires.It could be that something went loose


#5

I checked all my connections again, but everything seems plugged in fully and without any errors. For redundancy’s sake, I went ahead and redid the entire wiring process, but the result is still the same. I’ll check again tonight to see if I can drop the laser below 79 and still get curing. but from the brief look I had right now, the laser looked to be just as weak.

Edit: Is there a possibility that this might be a firmware problem? (Just taking a shot in the dark right now) I think my machine is on 1.16 still…

Edit 2: Tried printing again at 79, but now I’m not even able to get curing at this high of an output. Tried again at 83, and got the same result. I’m totally lost at this point. Any suggestions?


#6

It is probably a bad laser or power board. If you have a bench power supply, the I would suggest trying to drive the laser directly. One spitball is to check the laser aperture…it sounds silly, but I had a small spider take up residence in the aperture of an old HeNe laser, which led to much hilarity.


#7

I don’t have a power supply on hand readily, though I guess I could take the module out and take it to work with me… I did check the laser aperture to see if anything was blocking it, but as far as I can tell, everything looks the way it should. I really hope it’s not a power board issue, I don’t even see those up on peopoly’s site so I have no idea where I might even start looking for a replacement unless they are willing to replace it for me. At least I can remain a little bit tentative on the power board being the cause since everything else seems to work just fine, only the laser’s beam is really dim. Guess I’ll be out of a printer for a while since it’s the holidays over the lake, time to wear my patient hat wait for peopoly to get back to me.


#8

You could try this to check the laser:


#9

I can probably try that, but I’m not quite seeing the point. I know that my laser works, it’s just weak and not really curing anything at the expected power levels. If I had a power supply and was able to reproduce the voltage that matches whatever 58 on the settings is, then that might tell me whether it is the laser dying, or if it’s the power board not producing the right voltage. Maybe that’s the best way to go about it. I think I’ll still wait a little bit for peopoly to give me an official response, but at this point, I’ve spent more time debugging and troubleshooting than I have actually used the printer.


#10

If the laser is defective, it may not fire at all if powered by the battery. Unfortunately, without a laser energy meter and electronic test equipment, it is hard to narrow this down without doing swap-outs. If you knew someone with another Moai, then you could try your laser in their printer…

I am guessing you just got a bad laser.


#11

I went ahead and removed the laser from my machine. Does anyone know what voltage corresponds with a setting of 58 on the moai?


#12

hi @Tsiii

It could be the laser or the power board supplying the energy. Do you have device that measure the output level from the socket?


#13

Rather troublesome, but I could borrow one from work if I really have to (which it looks like I will) Below is how the laser looks powered by a cr2032. It does fire, though it’s really dim, but that’s probably in part due to the low voltage.


#14

Well, this doesn’t look promising. Barely getting any current through the laser at 5V

Does matterhackers carry extra lasers/power boards? I really just want to get my printer back up and running again…


#15

Here is a measurement of the output voltage at the laser pins. Laser power was set to 58 on the front panel. Voltage is measuring at 4.13V. Assuming 58 is supposed to represent 5.8 volts, then that would also mean that my board is damaged. As a side note, I did measure the voltage of the cable that plugs into the power board and got 24.1 volts. At Peopoly’s suggestion, I have gotten in touch with matterhackers (I bought the unit from them) and am a good ways along the process in getting replacement parts. Due to it being Chinese New Year across the lake, and celebrations probably being in full swing, it’ll probably be a bit before I get the parts I need. None the less, it looks like things are on their way to being solved. I’ll keep the thread updated as we work through this.

2/14/2019 update: I received a new power board and laser module from Matterhackers. There were some communication issues that are still ongoing that isn’t anyone’s fault (my emails are not getting through to their system for some reason). Regardless, I started going through things piece by piece. First thing, swapped out the laser. It fires fine, looks good. Checked the cross center code, looks fine. Swapped in the new power board. Laser looks even brighter, but the laser is static. The galvos aren’t moving. After doing my due research, I did some galvo testing. LED’s on the galvo boards light up fine, so the drivers are fine. The next item in the test is to GENTLY nudge the galvo mirrors to see if they are locked. They are not, which means the galvos are not getting power. Seriously? This is a “brand new” board. Is the quality control on these things this bad or do I just have bad luck in spades?

In the mean time, I’m going back to my old power board. Everything seems to be working fine (though I am still concerned if the laser is outputting at a voltage lower than it should be. If it works, I hope it lasts). I am now in the middle of running a test print at laser power 58 using my old power board. We will have to see how it goes. If thing’s don’t work out, then I’ll be running over two weeks of having one hell of an expensive paperweight. I do apologize if I sound annoyed, I’m just at my wits end with this machine. I really do want to adore this printer the way I see so many others do, but the problems I keep encountering are wearing me thin. Never the less, I do thank both Peopoly and Matterhackers for being supportive through all these problems. I’m just going to pray that this is the end of it.

2/15/2018: Ring printed successfully at the correct power setting of 58. Holes are open and everything seems fine. Print took a really long time (over an hour), but at this point, we are happy just to have the printer up and running. We’ll do more strenuous testing over the weekend, but for now, things are looking okay. Here is hoping that this lasts. Thanks everyone for your comment and help.

Last Edit: Looks like we’re back on track, here’s hoping it lasts for years to come!