[SOLVED]Trying to level, seeing some strange behavior on my posts


So, after replacing the peel motor, I was still seeing horrible prints, so I decided to go back to square one:
New vat, new resin (Peopoly Black), and re-level the whole thing.

It helped…mostly. The leveling posts look mostly correct now…gone are the huge layer lines, crooked posts and general garbage quality. However, something unusual still remains.

In the picture, you can see on the left the posts I am getting now, and on the right the posts I was getting months ago, last time I leveled. Note that the left post is blue (because that’s peopoly black, and I think it might be from before the reformulated it), but that’s not what is important. The left post also has about a 1/4" extra material around the first couple layers, making a thin skirt. Also, the letter on the top is almost completely closed up…it is barely visible.

I have no idea what is causing this. Is it software, hardware, what could be the problem here???

I am using Cura 3.4.1, with the Moai mods (not using 3.5 because problems started happening at the same time I upgraded to it…since I couldn’t be sure it wasn’t what was causing the problem, I went back. I did clean out the folders in Users folders when reinstalling, as per instructions). Using the Moai100 341 profile from August 2018. None of the ‘bed adhesion’ options (skirt, raft, etc) are active.

Laser power 56-58. I tried formatting the sd card with the tool from the wiki. I have the level posts basically measuring at 10.7-ish.

Any ideas? Has anyone seen this?



Also, as an aside, lowering the laser power had no effect on these issues, but it did cause failures where the posts would break off at the first few layers. (My belief is that while the 70% infill from light-bleed works, it also requires some local heat to have build up to make it happen reliably. On the first few layers of a print, that heat hasn’t built up yet, so the infill doesn’t always all cure, leading to shit-tons of print errors.)

Of course at 57 and 58 laser power, the cured resin from the posts sticks aggressively to the pdms, such that it makes a loud pop as the peel happens with every layer. Also not good.

Does anyone have a solution for laser power/infill, etc. that works for the peopoly resins?

Btw, I am using a heater in my Moai, keeping the chamber at around 85f.



I am having issues with the pillars as well. A disc prints on the plate at each pillar location, but no pillars.

Are the pictures at the end of that link what happens for you at low laser power?




No, the picture shows the strange effects I am seeing at the beginning and end of the print. A failure from the low power looks like a successful leveling post…until you touch it, and the post breaks away from the base because those first few layers are hollow.

If what you are seeing is just a bit of the base on the print bed, that usually for me means my leveling is too tight…try backing off the height a couple digits at a time (if you are at 1877, move down to 1875, etc) until you start seeing results. Don’t forget to clean out the resin tray with each failed print, as there may be (and probably is) some resin stuck in the areas where the posts were supposed to print. Also, if you don’t have a heater in your machine yet, that is something to consider. I started get a lot more consistent results as soon as I added mine (current problems notwithstanding).



Sorry to hear your issue, here is a survey we use to help us get as much info as we can from user so that we could provide best solution. Even if you might have provide some info already, please answer the question for the completeness.

support question:

Room temperature (best to be >25C):

What type of resin:

Build plate type: (Standard 1-piece / easy to level)

Vat: (Silicon vat / FEP vat)

What type Vat: (Peopoly Original vat, Recoated Peopoly vat, custom vat made by user)

Leveling measurement:

A, B, C, D (example 10.9mm)

Firmware version:

System Setting is default per Peopoly recommendation? (Yes/No)

Laser Power:

Z-reset position:

PM Motor Speed:

Z Follow Speed:

Software used to slice?

If using Asura,what version and profiles

If using Cura, what version and Profiles:

Infill %:



Room temperature (best to be >25C): Room temp 72 degrees f. Temp in build Chamber 86 degrees f.

What type of resin: Peopoly Black

Build plate type: (Standard 1-piece / easy to level): Standard build blate

Vat: (Silicon vat / FEP vat): PDMS

What type Vat: (Peopoly Original vat, Recoated Peopoly vat, custom vat made by user): Brand new ZVat. Fits perfectly. Please don’t ask me to use a Peopoly Vat. Inconsistent crap.

Leveling measurement:: A: 10.63 B: 10.77 C: 10.65 D: 10.76
Note that the problem has been occurring no matter what the post heights as I’ve attempted to dial in the level.

Firmware version: 1.18

System Setting is default per Peopoly recommendation? (Yes/No) Yes

Laser Power: Currently 57, tried 56, tried 58. Read the original post.

Z-reset position: 1876

PM Motor Speed: 15

Z Follow Speed: There is no setting called Z Follow Speed. However, Z Moto Speed is 2, Z Follows is 2, and Z Initial Speed is 2 (All as per the published firmware settings for firmware 1.18…in other words YES, I’m using the default system setting per peopoly recommendation. I feel like I’ve already been asked this).

Software used to slice? Cura

If using Asura,what version and profiles

If using Cura, what version and Profiles: Cura 3.41, using the 100 micron profile provided by peopoly as of August 2018.

Infill %: 70%, though posts will sometimes break at the bottom using lower laser powers and this infill setting. See my post above.




Today I tried slicing with Asura 2.21, using the 100 micron Moai profile included with it. No change in behavior. Still seeing the extra material around the bottom layers and filled-in letters at the top.

I wonder if there could be a piece of dust or something occluding the laser path, causing a bit of defraction? It would have to be before the galvos even, because it happens everywhere on the build plate.

Ideas, anyone? @peopoly? I filled out your form and everything here…how about a hand?

btw, this picture is me trying to solve this issue on my own, (also while leveling, of course).



Take a picture of your galvos mirrors if you can. I wonder if you have a spot on them or burn in somehow like I have had.



Loss of detail at small features and extra cured areas at the slow layers are two signs of laser flare. Cleaning the optical path would be my first attempt at solving that issue.

I think it would be helpful to make a photo of the laser spot before and after cleaning, but i’m not sure if it’s still possible to activate the laser without moving the galvos.

1 Like


Thanks, nbltsgndpfrdbrms, that sounds like some some actual helpful knowledge!

If there is a way to get the laser to just sit there and fire still, I didn’t find it, so I had to skip laser dot photos. However, I did go in and re-clean the galvo mirrors (they look real good to me, but it is so hard to tell with little tiny mirrors), and the drip guard glass. Also, the checkup document on the wiki mentioned that the front of the laser should be flush with the housing, and mine looked like it was maybe (technical term here) half-a-smidge forward of that. I re-seated it to be dead-on flush.

This felt like progress and gave me a warm feeling.

Unfortunately, I ran a test and got the same results.

Is there anything else I’m missing in regards to cleaning the optical path, or anything else I can do??

timesep, I took a picture of the galvo mirrors, and I don’t see any blemishes. This picture is before I just cleaned them, so the little bit of dust there is hopefully gone. Cleaning mirrors is stupid frustrating, because the act of wiping off the dust ionizes the mirror, so it just attracts more dust. I would think if dust on the mirrors was the issue, though, it wouldn’t cause identical failures in all corners of the build plate, both before and after cleaning (even if it got dusty again, the new dust would be in different areas, and produce a different fail).



the only reason i was thinking it was a mirror blemish was from what i’ve seen on some of my prints where i start to see crazy results inside some of my prints, which was determined to be flare from a burn spot on one of my mirrors, thankfully it came off, but reared its head again recently, It was just something to look out for.



Oh, I appreciate the suggestion, for sure! I mean, I have no idea how to solve this.

The mirrors seem clean, the glass is clean…I guess I don’t know about inside the laser itself…is it possible some dust might have gotten in there? Seems unlikely, but something has to be causing this…how would I even clean that or rule that out???

Hey, @peopoly…I know it’s only been 3 days since I filled out your form up above, and that doesn’t seem like a long time, but it feels like forever ago to me over here. I’d love any insight you got. How do I fix this??

1 Like


since you are using asura, the profile is correct (I know you are an expert from past conversation about custom Cura profiles). The only possibility is

  1. light being affected

  2. a layer shift in the initial layers due to very strong suction

  3. is the likely reason and you want to check mirrors, laser tip and vat bottom
    it is most likely if this happens no matter where you print

can you also use the latest pre-sliced gcode
this version was updated Sep 2018 with an easier to remove base
use that to see if the problem persists



Hey @peopoly!
Thanks for getting back to me. So yes, I think the light is being affected. I have checked the galvo mirrors and the vat bottom. The vat is brand new and completely clean, and the mirrors look good to my (untrained) eyes. So my next question is:

HOW do I check the laser tip? HOW do I clean it?

edit: So, out of curiosity, I ran a print with no build plate in, and a piece of paper on the bottom of an empty resin tray. On the first few layers, the laser moves really slow, so I thought I might be able to clearly see if there was any problem (using the special glasses for safety, of course).

This worked real well to pretty much confirm that there is a huge (almost 1/2" from side to side) halo around the laser dot. I tried taking a picture, but the pic is pretty worthless. The halo seems to almost have a blotchy shape, rather than being a perfect circle, and perfectly moves with the laser dot.

Could this be caused by dust or dirt or something, or am I looking at a bad laser? If dust could be the culprit…I am back to HOW do I clean the laser tip??



I kind of touched up this picture, as the camera can’t see what the eye sees. There’s the really bright spot in the middle, and a lighter weird blotchy shape around it. The blotchy spot moves exactly with the laser.

I tried cleaning the mirrors again, I took the drip guard completely off, I took the resin tray out, and am just firing on paper. I blew compressed air into the laser, and when that had no effect, also took a fine sable brush and dusted the laser laser lens way back in there. Nothing has changed the spot in the least. I also took the laser out of its socket, and fired a pen laser at the mirrors. The spot it makes on the paper is identical to if I just fire it right at the paper, with no blotchy spot present.

Once again…help?!



hi @darkplatypus

it is hard to capture the laser spot with camera lens because of the flare. See if you can run a print and look at the first layer with laser power of 50. If there is halo, like broken up lights around the laser spot, then that would cause scattering curing. If you don’t see any thing on vat. mirror or galvo protect that would cause that, then it would be the laser. At that point, let us know via email to support (we got the latest email from you) and we will take it from there



Hi @peopoly,

So, the halo around the laser light looks just the same at 50.

Actually, it does look a little different…the angle of the ‘blotchy’ shape is changed…it used to ‘lean right’ as it were, and now it is more ‘straight forward’.

Really, I think this really does confirm a problem with the laser itself, because as part of my troubleshooting, I re-seated the laser, and probably put it back in the mounting at a slightly different rotation than it was mounted previously. Thus, the halo appears at a different angle.

I will send you guys an email to support. Thanks!



Received the replacement laser installed it and tested. That fixed it.

To summarize, I had two problems that occurred more or less simultaneously:
1: Intermittent peel failures
2: Loss of detail caused by lens flare from bad laser

The peel failure thing was a real pain to track down because it was intermittent. I would change something, and then it would work, and I would think that fixed it…until it failed again. Eventually solved by replacing the peel motor.

Excited to be back up and running again!

1 Like


Checking the gavo mirrors are a must and like this chap the laser if galvo’s are ok. your prints will have a flare around them instead of being crisp and that’s the dead give away. my galvo had a purple mark on it and it ruined a lot of prints till i took the side off and saw the issue. so do yourself a favor if you have failed prints or prints not curing or pulling apart after the first few layers and CHECK THEM GALVOS!