Solved: How to fix LF -> CRLF in Cura Mac OSX

#1
  1. Open the Extensions>PostProcessing Menu
  2. Add a Search and Replace script
  3. Check “Use Regular Expression” and enter “\n” “\r\n”
    25 AM

Now,when you save a GCode file from Cura, it should be DOS formatted and work with MOAI.

5 Likes

Mac OSX test group
Test prints work but exports from Cura not printing
NEW to setting up print files on Moai Help!
Mac 10.11 slicing and firmware problems
Cura Moai Edtion for Linux (unofficial)
Can only print the test items
Lost digital translation?
Printer only printing test designs
Strange happenings; super short layer times
Build plate starts in the air
Moai malfunctioning
#2

has anyone tested this yet?

this looks like a clean solution while we try to sort out in the firmware.
nicely done @kelnishi

0 Likes

#3

This totally works… thanks sooooo much!!!

0 Likes

#4

Yes it works flawlessly

0 Likes

Need help setting files up with Cura on a Mac
#5

I haven’t been able to get this to work. Is there some form of thing that needs to be done to enable it after the plugin is created.

Also, the plugin seems to disappear when relaunching Cura.

Fortunately, I have a PC I can fail back to if I can’s solve this.

0 Likes

#6

This works fine for me. After the plugin is created you should be able to just close the window, and Cura will re-slice. Unfortunately at the moment you have to add this script every time you launch Cura, hopefully this will be addressed in future builds.

0 Likes

#7

This works for me as well

1 Like

#8

Is this being solved somehow so we don’t have to enter the script EVERY time we load Cura?

0 Likes

#9

we are trying to bake this in Cura Moai edition for OSX. not successful yet

1 Like

#10

I’m seeing some strange behaviors on the Mac when I slice multiple models from a single Cura session with the EOL fix. The first model prints ok. I power cycle. The second print starts, but then behaves erratically - print “completes” after one layer, Z continues moving vertically during first layer, etc. The only thing that seems to work consistently is to restart Cura, reset the post processing, slice, and save after each model. Incredibly tedious when I have many models I want to prep. Has anyone else experienced something similar?

1 Like

#11

we hope 3.3 fix this and we are aiming for launch this month

1 Like

#12

I’ve concluded that for some reason Cura’s post-processing script doesn’t always get applied correctly. Using unix2dos on gcode files works consistently - plus you can apply it with unix2dos *.gcode to batch process files. I haven’t had any problems since I switched to using it instead of the Cura script.

0 Likes

#13

Could you please elaborate on how to use this method?

0 Likes

#14

Sure! IMO, it’s easiest if you have homebrew (https://brew.sh/) installed on your Mac. It’s a great way of automagically managing command line package installations and upgrades.

  1. Open a terminal window
  2. Install homebrew by cutting and pasting this into the window:

/usr/bin/ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”

  1. When that’s done install unix2dos by typing:

brew install dos2unix

  1. Now you’re set! Just go to the directory (via terminal) where your files are. For example:

cd Desktop

  1. Convert gcode file(s) by typing:

unix2dos yourfilename.gcode

or if you have more than one file to convert

unix2dos *.gcode

2 Likes

#15

Thank you! I will try this while waiting for Moai Cura 3.3 that hopefully will solve this issue permanently.

0 Likes

#16

We are building 3.3 so stay tuned

2 Likes