SD card suddenly not working.....help

#1

@peopoly @Lyndondr Suddenly after following the same procedure as I have been with growing success on prints, this morning, My Mac was not recognizing the SD when inserted. I tried EVERY possible issue and cure for SD cards not seating or working…for about 2 hrs from Youtube suggestions and no luck.

Thinking it may be my SD slot, not the card, I bought an external SD card reader with usb port plug. The card DID show up in finder…and I opened it to see all files in tact…g codes, etc. HOWEVER, it will not allow me to add or remove any files now, so I can’t load new g-codes to print. It does not indicate it as locked or prompt as such.

I was looking forward to a weekend of printing fun…but this is now my new problem. Any suggestions? By the way, I have had so many complications using a Mac for the Moai from the get go I bought a Windows PC I will get mid week. lol In the mean time…HELP appreciated. I tagged you two guys that have helped me previously!! See comment and photo below in next reply
~Tom

0 Likes

#2

28 PM

Cura shows this error regarding SD card not able to be uploaded to now… I have done nothing new to my settings…the SD card just suddenly stopped functioning

0 Likes

#3

Have you tried a new/different SD card? I think mine might have been duff too…

0 Likes

#4

No I would need to get a card recommended and then would need some guidance as to how to get all the data for the Moai off this SD provided with the kit I assume? I have rarely had need to mess with SD cards other than a digital camera I once owned. I just want to get this solved so I can get back to printing this weekend. Finally am having success with prints before this happened and derailed me…lol

0 Likes

#5

Well, erm I would try another SD card! Don’t you have a few lying around? ( I seem to! ) :slight_smile:

If not then buy one I guess - they are pretty cheap and it sounds like yours is defective. Its a cheap possible fix anyway especially if you are dead keen to get going. I know they recommend the Kingston card but I had one of those and I have had two fails with it (exact cause unknown) so I have switched…

In terms of getting all the data off - I just copied it onto my HDD and then onto the new card.

0 Likes

#6

Yah I was posting a request here to recommend a card. Then what to do…I CAN’T access any of the data on the card originally with the Moai. Isn’t their data on that original card necessary for printer to function or can I just buy an SD card, load a g-code on it and plug it into the moai?

0 Likes

#7

I’m pretty sure you can use any SD card - just make a folder called ‘gcode’ and stick your gcode in there! I would upload the logo file but .bmp seems to be not allowed here!

0 Likes

#8

OK so the SD card is just to transfer the Cura G-code to the Moai is all it is for, after it functioned as having test prints and such initially is what you are telling me…I buy a 4GB Kinston and I am set? OK! Thanks!

I booked out the entire weekend here to tinker with B9 Creator, Meshmixer and Cura…I was JUST getting things working better and better and then…pooof…the darn SD card stops me cold. lol I will head to Rite Aid for an SD card here shortly.

0 Likes

#9

What do you have for SD cards?

0 Likes

#10

On a MAcBook Pro Only SD card I have is the one provided with the Moai currently…was working fine till this AM. Tried it on my larger Mac OSX and same issue… Card won’t allow anythng but read. Also, there is no tab on this card like some I see…(the little one for locking). Also there is no prompt message that says the card is locked…just the message you see here on my post. (photo) I can’t remove or add files like before…they bounce out if dragged into the folders the way I have done before.
Also, If I use the “save file to box…” on cura for MAc, it used to save it onto the sd card…now it doesn’t appear saved anyplace.

0 Likes

#11

This might be helpful.

0 Likes

#12

@Lyndondr @peopoly OK There was never an issue with the laser firing. The issue I explained above. Bottom line…PLEASE make this as simple as possible as to where I go from here. I have read through countless issue threads here to the point where I am forgetting even what this machine does!! lol
I need to print some test pieces this weekend. I am fine with what I have learned on Cura, B9 Creator and Meshmixer. Lot’s of struggle with getting this far, the Mac has made things a lot more complicated it seems and I just want to have FUN finally and PRINT!!!

SO… Just tell me this. I am going to Rite Aid to get a new SD card. Trying for a Kingston 4GB!! From there…how can I just get my g-coded model files into the Moai s slot an PRINT!!! lol

Forgive me if I sound impatient. I just have spent SO much time on stuff like this…I thought my biggest hurdle would be slicing and structure software learning curve…I am getting that…was getting some great prints finally !! I just need a reliable way now to get my data in that Moai’s pie hole!! lol!! Can I load a g-code into the new card I buy and plug it in the Moai an be on my way?

0 Likes

#13

Yes, just put the sliced gcode file in a folder called gcode like @moddhayward said. You don’t have to have anything else. The logo file is displayed if the card is inserted before power up.

0 Likes

#14

Awesome I always thought there was other data in the original card that talked to the hardware. This helps explain. Again, thanks so much!

1 Like

#15

@peopoly …Followed the above Directive, but could only locate a Lexar 16GB SD card. Which I assume would be fine. I dropped in a previous g-coded model that printed fine last week…onto this new card into the restarted Moai. No print. The laser looks like its scanning properly, but no model is on the plate. Not even sure where to go from here… Suggestions?

0 Likes

#16

Assuming nothing has changed on the machine. Try the ring test gcode. Use the link below for the files you might be missing.

http://wiki.peopoly.net/doku.php?id=moai:files

0 Likes

#17

Sorry…which or what one of these lines of info am I supposed to use and how? Remember, I am 100% new to this as to 3D printing stuff!! I tripped accidentally on some place in one of these Moai forums as to recommended Cura settings with Moai edition fro mac. Thought that was all I needed. I

I just "formatted " the SD card per your list above recommendations…I never use SD cards so if that was a must, I had not done that part. Downloaded ring test and it’s starting so far.

0 Likes

#18

Ring test printed. However, the base was just barely adhering to the build plate compared to when I did the test last week from the original SD card. Also, is it normal to have this odd recessed marking on the models bottom platform? Other models that worked well were much more stuck to the build plate and flat as I recall.
Funny thing is prints were working better last week when I just used Mac Cura, Meshmixer and b9 Creator with no recommended Moai adjustments from threads here other than cura fill raised to 70%. Just puzzled…back to square one here.

0 Likes

#19

It would look like the base was sliding around until the suction forces were stabilizing. To increase the build plate adhesion add 1 or 2 to the Z reset and then maybe check the 4 corner leveling print to check level and overall size to eliminate theses factors from your troubles.

Has anyone asked you what the temperature of your print environment is?

Be sure to use a rubber scraper and make sure the resin is mixed good if has been sitting or at least once a day.

Do you know about the troubleshooting chart?

0 Likes

#20

I will try all this. Z reset of cura? mixed up resin in vat with rubber spatula…temp was 74 F …as taken with a high quality digital thermometer.
I meticulously leveled the machine twice.

I will sift through trouble shooting I guess again

0 Likes