SD Card Reader Issue? - Nope, something else

#1

Hi there,

This is my first post in the forum, and I tried my best to research this before having to ask the community, but I just this morning started having a bizarre problem with my machine.

Everything has been behaving itself up until today, when I tried to run a print and it started at layer 958 of 960 and it literally just pointed the laser in the front left corner of the vat and sat there. I shut the machine off, started back up, and after some standard maintenance tried the file again. This time it was on Layer 1 of 0 Total layers, and the PM motor simply lowered and raised the vat over and over again without pausing.

I’ve fully formatted the SD Card (using the included 16GB Kingston card) with the recommended tool and have tried different gcode (all from Asura 2.21/2.22)

I opened up the machine and took a look at the SD card reader pins and they all look pretty clean - no breaks that I can see, though I’m going to hand it off to an electrical engineer I work with for a closer look later today.

Based on the symptoms, does it look like it could be the card reader? Any other theories out there?

Also, I’ve been running this machine for roughly 5 weeks now and the knowledge of this community has been very helpful, so thanks in advance! I work as a technical specialist at an MRI research laboratory, and this machine is a crucial part of my tool set, any suggestions would be greatly appreciated!

0 Likes

#2

When you used the sd card format. Did you use the advanced options and choose the overwrite erase?

0 Likes

#3

Yes I did.

Additionally, I’ve since ruled out the card reader. I just went through the process of updating the firmware (from 1.18 to 1.18, not really an update I know :slight_smile: ) and that worked just fine, so something else is definitely going on here.

@peopoly any suggestions on what I should check?

0 Likes

#4

Have tried putting your gcode file onto a different SD card?

0 Likes

#5

Unfortunately I don’t have another one to use at the moment, but I can certainly test that out soon. It seems odd that it would be the card though, as the firmware ‘update’ went flawlessly.

0 Likes

#6

I have a designated card for updating firmware and another card for gcode because they do not work the other way around. Don’t ask me why :smiley:

1 Like

#7

Thanks for that, well I’ll certainly try another card then. I’ve done a fair bit of reading about the SD card reader on this machine today. Seems to be a weak link for a lot of folks.

0 Likes

#8

I would also try downloading a pre-sliced model and seeing if it misbehaves. If it doesn’t, then I would look at your slicing workflow.

The card reader is a known issue. Peopoly has announced plans to redesign it to use a cable connection. I shimmed mine to reduce the tension on the pins.

0 Likes

#9

Based on the symptoms, as you said, they are all indicate that the SD card or the SD card reader fails.
this is not a rare problem that users have and usually the way to fix is to format the SD card or replace the reader.
you will know that SD card fails when it doesn’t print the way it should or multiple prints collapse on each other. This could be fix by reformatting the SD card
If the problem persist, try the presliced gcodes in the SD card as @Paradoxical_Cat suggested

0 Likes

#10

Thanks @peopolysupport and @Paradoxical_Cat

I will certainly exhaust these suggestions and will get back to you on any progress that is made!

0 Likes

#11

@peopolysupport It seems that the issue was with the SD card itself. Though I could use the included card to update the firmware on the machine, the gcode files are not able to be read even after reformatting the card. I’ve since retired that card and went to an 8Gb Micro SD & Adapter and all is back to normal again.

It’s very odd that this happened all of a sudden though, and I hopeful that it doesn’t suddenly happen again with this new card.

Thanks!

2 Likes