SD card (No folder) / (No gcode file) SOLVED!


#1

Hi guys. Just want to let you know that I struggled with reading the SD card that followed the Moai.

Problem: Moai couldn’t see the Kingston SD card that followed. I tried with my own SD card that I use for my DSLR camera. It could see the folder, but it couldn’t see the gcode file. I wondered about the SD reader pins and soldering or main board. It was none of that.

Solution: I completely formatted the Moai Kingston SD that followed,- and suddenly the Moai could see the folder and the gcode file. Great!

Henrik.


Possible hardware issue with Moai, support needed
#2

I am getting the same problem and this tip didn’t help. I tried a new SD card, I tried putting the GCODE into the root and into the gcode folder, but it can’t see any files or folders. Anyone else having this?


#3

I think you should still see the gcode folder but make sure your file names are less than 26 characters. Other than that there is another post about the solder connections from the card reader that break free.


#4

Thanks Lyndon, I checked and it turns out the bottom row (closest to the PCB) of solder connections never got connected. It seems that when it went through the oven it was tipped up so it was resting on the longer ones in the back and the plastic in the front.

I had a soldering iron that would work, but I needed to remove 2 of the longer pins to reach all of them. It wasn’t too bad, just remove 2 of the longer pins that obstruct the access of the bottom row by counting in to the 3rd pin for each side. If you have a sharp point on your soldering iron you should be able to lean it in to get one on either side of where you removed the pin, plus the one directly below.


#5

Did you get it working? If not, please email us and we will get you a sd reader replacement.


#6

HOLY SHIT

i love you. been back and forth for the last 30 minutes. i tried anything and everything except that. it’s fixed now and i can stop stressing :slight_smile:


#7

Bump! I had this same issue. Noticed that reseating the sdreader sometime made it work for a bit so I inspected the board and sure enough - cold solder joints on the bottom row. After reflowing all the connections I have no more issues. This is probably something that needs to be checked on all kits going out.


#8

thanks for the feedback. We found that some got pulled off after we did a print test before dissembling for shipment. The new sd card reader has stronger pins.


#9

So this could be my problem. I sent Matterhackers a theory that possibly it could be a bad solder joint. Seeing this is actually a common problem I bet I could have saved myself $60.


#10

Here is my board…


#11

Almost reformatted by SD card until I read your post about 26 characters. That was my problem. So if you see the folders and other gcodes that have shorter names, make sure your file name is less than 26 characters.


#12

Just here to say that I had the same problem.

I de-soldered the upper outer pin, pulled it out, adjusted and re-flowed the inner problem pin, then re-soldered the outer pin.


#13

if problem still arise, contact your reseller for a new SD reader.


#14

Thank you.

It’s all good.

Passive PCB in a DIY + forums + responsive dev = happy people. :slight_smile:


#15

Yea, I was having issues with it too, i used a heat gun to reflow the pins and formatted the drive and it cleared the issue up. They sell the heat guns at harbor freight for like 15 bucks too. Just remember to keep your file names short too, under 26 characters i think.


#16

I’ve recently experienced this problem. I get a ‘no folder’ error message when the SD card is inserted. I’ve reformatted the SD card and checked the connections. I spoke to Peopoly support (via Facebook) almost 2 weeks ago and it was agreed that a replacement SD card would be shipped to me (I’m in the UK). I’ve heard nothing from Peopoly since.

Please can someone advise how I can escalate this issue. I’m sure you can appreciate my frustration as my printer has been unusable for almost 2 weeks now.

Thanks, Luke


#17

I had problems with the SD card that came with the printer. I went and bought the cheapest SD card I could find from a local store - no problems after that. Instead of waiting for a card I suggest you buy a new.