Printer Won't Boot! (Also, X-axis was inverted?)


#1

Problem 1

I put in a new SD Card with the v1.18 firmware on it to try and update the printer, and it just stopped working. I can push the power button, but even letting it sit for 1 hour, there is no change. Just a black screen, no matter how many times I try and disconnect/reconnect power. The motors for raising the Z-axis and tilting the bed also never start. It is dead quiet. But the green lights on the galvo driver boards are green, so I don’t think there is a problem there.

This all started because, while I have been printing successfully for a while now, the other day I decided to try printing something with a thread.

I realized the threads printed left-handed when the model was right-handed. I’ll attach a pic. for reference.

Anyway, upon checking the A,B,C,D corners to see how things print, I noticed that the Y-axis is fine, but the X-axis is actually inverted.

So, instead of the corner A being to the front right of the door, it is actually to the front left!

Screenshot_1

It looks like there is a motor direction or pin connection wrong somewhere?

For the record, all the X-related cables are connected to the X Galvo Driver, and all the Y Galvo drivers are connected to the respective Y Galvo Driver board.

So, I decided to update to 1.18 to see if a firmware update would fix any errors. And what happened? The printer stopped working!

Help!!


#2

Take a close look on the SD Card reader board. I suspect some pins are not making proper contact. This can cause the printer to act the way you describe. Resolder the pins if you have the right tools. Search this forum for SD Card reader problem for more info.

Regarding inverted X axis I actually had mislabeld driver boards - after you get your printer up and running you could try to swap the cabels.


#3

Thanks for the reply.

Actually, a few months ago I posted about the SD card solder issue, and solved it by resoldering the joints. I’ll take another look, but I did a pretty good job fixing that problem already…

As for swapping the X and Y boards, I tried switching all the X and Y cables already. (For me, the board labeled X was in the back closest to the Z-axis, and the Y-board was in the front, whereas the Install guide says they are switched)

I’ll take a look at the SD card slot again and do a continuity test. I don’t think that is the issue this time though…

EDIT:

I checked the SD Card. The pins are all soldered correctly, and the continuity test shows them all in order. It’s not the SD Card.


#4

for the booting problem,

unplug the sd card reader completely to boot
check to see if there is light on driver
also send an email to support@peopoly.net about this thread

and for x-axis inverted, it is almost always cables swapped. It could be data cable, power cable or the galvo cable. check the diagram for the PCB connections or take a picture of your connections


#5

I have tried removing the SD Card reader completely, and booting, but still no luck.
The motor board lights are on though, as shown in the following video I took:
https://www.youtube.com/watch?v=4NQ-iB4HXHo&feature=youtu.be