Printer stops booting


#1

Hello!

I’ve had my printer for several months, and have very happily printed 100+ objects with it, mostly D&D minis, with great results. Unfortunately a few nights ago the printer started behaving oddly, and now it seems it won’t boot up. Pardon the length of this, I’m just trying to include everything that might be helpful to debug this.

  • After a long series of good prints, I had a bad print, with the cured resin remaining attached to the bottom of the tray rather than the platform. The strange thing was that the pattern of the cured resin was nothing like the model I was trying to print, it was in short strips spread out over a wide area of the tray, rather than in the spot where the model should have printed.

  • I removed the tray and cleaned and strained the resin, and tried again, with the same result.

  • I tried printing the P_yuan-test.gcode, but the patterns it showed on the paper were nothing like normal, the laser moved in a couple of tight circles, and then stopped showing at all. When I ran this test after I first built the printer, the laser kept running over and over the same circle, but here it ran for 5-10 seconds and then stopped showing.

  • I then turned the printer off, reformatted the SD card (FAT32), and restored the various gcode files, but when I put the card back in and turned the printer on, the screen didn’t light up and the z-axis didn’t move as it normally does when the printer is powered on.

    I see green lights on the two motor control boards, and when the printer is first turned on the mirror kind of flicks into a different position, but there’s otherwise no response.

    I’m running the 1.18 firmware, with the new recommended settings, and have successfully printed several dozen objects since I did the firmware upgrade, so I wouldn’t think it’s related to that. I tried putting the 1.18 firmware on the SD card and booting with that to see if re-flashing the firmware would fix it, but 10-15 minutes after powering on, there was still no change, screen is black.

    I don’t see any burned out components, and I’ve wiggled and re-seated all the cables. Powering off for several minutes to an hour doesn’t change anything, including fully unplugging the power.

    Help! I adore this thing, so I’ll do anything I can to fix it.

    This shows the green motor control lights:

I have a couple of other images, but I can only post one since I’m a new user.

And this is a video showing the mirror flicking: I turned the printer on and off 3 times, and you can see the mirror flicking each time.

Any help is appreciated!

Denis


#2

Hmm, I guess it didn’t like my video, here’s a link to it which should work:

https://drive.google.com/open?id=1Zk7PNy5OVOyZxDYPeor5rYKC2ymaIgeDhA

Denis


#3

have you tried to follow Moai boot up sequence?
http://wiki.peopoly.net/doku.php?id=moai:bootup&s[]=boot


#4

@peopolysupport
Your response of:

would seem very unhelpful to me if I had provided all of the information that @DenisM did. @peopoly has asked us to be patient with you and to try to help you mature as their support person. The best advice I can give is for you to read what is sent and to not feel obligated to just give a response regardless of whether it is actually helpful. There are certainly some new users that ask basic questions, but this is not one of those times.


#5

Hi @peopoly,

Thank you for the response. I’ve followed the bootup sequence on that page, and also did the steps for the end sensor check as best I could understand them.

The boot up behaviour I see is that when I press the power button, the blue light around the power button comes on, and the green LEDs on the motor control boards light up, along with the mirror flick that I described earlier. However there is no backlight showing on the LCD screen, and no other lights that I can see. There is no movement of the build platform or the peeling mechanism, no motors run at all after powering it on.

The above behaviour is the same regardless of whether I power the printer on with no SD card, an SD card with no firmware on it, or an SD card with the 1.18 firmware on it. This SD card is the one that I received with the printer, and as I mentioned, I recently did a full reformat of the SD card to FAT32.

I hope this helps! Please let me know if there’s something else I can provide?

Denis


#6

hi Denis,

From the video, it seems your galvo mirror is jammed. Try this:

  1. turn the power off
  2. use finger nail to move the mirrors a bit so they are not locked into each other.
  3. turn the power on and try the circle test scan

#7

and turn on the printer without SD card @DenisM


#8

Thanks @peopoly, but I’m not sure the mirrors are stuck together. I took another video with me turning the printer on and off (with no SD card inserted), and I believe the two mirrors are moving independently.

[https://drive.google.com/open?id=1nugvBA7JfUxZRc4RrHfDToktCvxEUAfruQ]

Given how the mirrors are moving in that video, should I still try and move them with my finger? I’m a bit worried I’ll get a thumbprint on them or break them somehow.

Thanks!

Denis


#9

thank you for being patient with me, I’ve got more experience since the last time answering your question, i will never make the same mistake again. For this, i think you misunderstood that i was just try to get more information from Denis and in case he didn’t follow the boot up sequence i sent him the link.


#10

let’s back track a bit.

  1. “was that the pattern of the cured resin was nothing like the model I was trying to print” was its same size but compressed or just completely different size and things. This is usually SD card i/o errors. most can be fixed with formating with SD formater
    https://www.sdcard.org/downloads/formatter_4/
    if that does not fix this part, then a new sd card reader may be needed (you mentioned you reformated card so now it is likely the reader)

  2. which brings to the turn on with no movement. while it sounded like one of the cards are burned out, we have had users with bad sd card reader that caused this problem.

so let’s do this first:

  1. unplug the sd card reader from the mainboard and try to boot up again
  2. if that does not take care of it. there is a good chance you may need a new power board

#11

From the video they dont look like they will/are touching each other… (i dont know if that was what peopoly meant when they said they could be locked together)

But dont be afraid do touch them… without your fingers!!! I’ve cleaned my galvo mirrors more than once. Just use a swab of some sort to push them… something that wont leave any marks on the galvos!

With the printer off you should be able to turn them no problem and check if they in fact if ever touch each other.


#12

Thanks for this, I appreciate all this help. I’ve removed the SD card reader (took out the two screens attaching the support to the frame, and then just pulled it off). Unfortunately, I’m seeing the same behaviour: when the power switch is turned on, the mirrors flick into a slightly different position, and then nothing. sadface

Are there parts I can order to replace the power board?

Denis


#13

if you bought it from a reseller, they should have the part.
if not, can you email us at support @ peopoly.net? we will take care you from Hong Kong


#14

I purchased the printer from MatterHackers, so I’ll contact them to see if they will sell the boards separately.

I’m sure I’m not very familiar with debugging this, but I would be inclined to think there might be a problem with the firmware rather than the power, since I don’t see any issue with the lights on the controller boards. Is the firmware on the power board, or is it on a different board? If it’s on a different board, I’m wondering whether I should get both the power board and the one with the firmware on it, to save time.

Denis


#15

@DenisM

Matterhackers should it in stock. Go ahead and reach out to them to replacement. It is likely not firmware since the same firmware is running on many users’ machine. sometimes power board broke but still powers some but not all parts


#16

Thanks very much, I sent them an email over the weekend asking about what boards they have for purchase. I appreciate the help! And also thanks to @Leonardo and @glassTransition for your comments, it’s nice to feel you’re not alone in this!

Denis


#17

Hi all,

Just to close this off for others who might see this thread in the future and want to know the solution: I got a replacement power board and also the main board (the one with the firmware on it). Replacing the power board didn’t help, but replacing the main board did. So I presume something bad happened with the firmware image. I was able to print several models last night.

Now that I have a spare main board, is there a way I can re-flash the firmware on it, so I can make a valid spare out of it?

Denis


#18

I am having the same issue now…

I can push the power button, and the blue light comes on, but the LCD remains dark and the motors never do any of the normal boot-up sequencing.

It looks like the main board is dead on mine too…and all I did was put in a new SD card to try and update it to 1.18!


#19

the update process takes 30-50 seconds to finish.

try to boot without SD card first. or at least let flashing process finishes. It is never a good idea to power off a printer while it is been flashed.


#20

Hi @Tynkerd, I’m sorry to hear you’ve had the same problem as I had. For what it’s worth, I haven’t had any problems with my replacement main board, so it wasn’t a chronic issue for me. I hope you’re able to get a replacement main board, either from your reseller (which was Matter Hackers for me) or from Peopoly.

Best of luck!

Denis