Phenom L not recognizing USB / no print files available

Hello,

I have a Phenom L that i’ve done a lot of prints on. I haven’t used it since last fall. Now, when I plug in a USB drive with print files on it (including the known good test file from Peopoly), no files show up in the print dialog option:


The printer is on the F2.11 firmware, and I’m using Chitubox Beta 6.4.3. The USB is wiped and reformatted as FAT32. I’ve tried two different USB drives, and neither work. Both are known good working USB drives.

According to this guide: https://docs.google.com/document/d/1OP2G2Ssry3viXyU9ENfPdLFxQgSsIsWQ2Mr1lI7ndV4/edit

This suggests that the internal USB cable is broken, but I find that hard to believe since it hasn’t moved since I used it last.

Are there any suggestions for what I should do?

Thank you.

Never mind. The 3rd USB drive I tried is working. It’s USB 2, and the other two were USB 3. Not clear what the issue is, since one of the USB 3 drives is what I have done a lot of prints with.

Perhaps the printer needed to be power cycled a lot of times, or I’m missing something. Any how, I’ll leave this up in case someone can offer some insight.

hi, replace the USB flash drive or reformat the USB flash drive. And check whether the USB port is loose or there are foreign objects. Please clean the usb port with ethanol. And check


If the above check still does not solve the problem, please contact us by email so that the peopoly technical team can help you

The 3rd usb drive I tried worked, and I had a successful print. Thanks!