Phenom L Firmware Update Issue?

I’m attempting to update the Phenom firmware to 2.11 using the instructions at

but I’m running into an issue during the process.

  • Step one, installing “FPGA_H1_P321_F11_CTB2_3840_2160_25HZ.CBD” - WORKS
  • Step two, installing “Phenom L chitubox f211.gcode” - WORKS
  • Sep three, installing “update.LCD” does not work. “Unknown file format”

I’ve attempted to power cycle the printer, and run through the process again, and get the same result. The linked video for the update process skips over the chitubox f211.gcode step, installing only the fpga CBD fiel and then the update.lcd file. I tried this as well, no luck. I also tried two other memory sticks formatted fat32 and ntfs, a fresh copy of the firmware files, and tried creating the stick/copying files from both a mac and two windows PCs…

As of now the information screen version reads “V4.2.22_LCDH /3740x2160 /F2.11” , and the printer does function, but will still only read cbddlp files and not the CTB format. What’s happening, and how can I get the complete set of update files in? ctb files are substantially smaller and seem to process from the slicer much faster, so this would be great to have.

  1. Firmware.
    Latest F2.11 firmware has been tested and working well for many users. Here is the instruction:
    https://docs.google.com/document/d/1jeMUR7WCTeFyqjiOd3JBpX50Mp7Jz5eZ5I6PVmnpkTA/edit?usp=sharing

  2. Software
    Please stay with Chitubox 1.6.4.3 Beta as suggested by the Setup guide. The 1.6.5 is quite buggy and cause some printers to function incorrectly. We have not had it tested enough to recommend it.

Make sure you clear out Chitubox from any version before installing the intended on:

Here is how:
Chitubox often has leftover files from previous versions and sometimes it corrupts new versions. Factory reset does not always work. This is how you can get a clean Chitubox installation:

1 Uninstall ALL chitubox software on your computer
2 Delete all the leftover files in AppData\Local under user directory
There may be more than one directory and the name of the directory always start with chitu
3. install the chitubox version you want, we recommend Chitubox 1.6.4.3 Beta as it has built-in Phenom profiles and is less crash-prone with larger model files

"7. Go to Print function. Select update.LCD and print. "

This step does not work. I have this document already and went through all listed steps as well as my own troubleshooting efforts.
Expected result is that update.LCD will install and restart the printer, and the information screen will show “V4.3.4_LCDH” but what I have is “Unknown file format”, no install or restart, and the info screen still shows “V4.2.22_LCDH”

After the installation is complete, shut down and restart.

I have - several times. The final step is not installing, the update is not completing. I am not able to print .ctb files.

it is step one that is adding the CTB functions, not step 2/3. And in the update instruction, it also mentioned that users coming from 2.9 may not able to update the LCD file since it is the same one.

What we recommend you to do is to go back to F2.8 and then upgrade to F2.11

also make sure you don’t mix files
F2.8

Phenom L F2.11

also it is best to share screenshot of the info screen to help us confirm

Finally had a chance to check this. Same result reverting to 2.8

  1. FGPA file works
  2. gcode file works
  3. update.LCD - “Unknown file format!”

Restarting the printer, I can see from the info screen that 2.8 is active, retry the above steps, no luck with “update.LCD”
So, I try the 2.11 files, assuming the older update.LCD is what’s already in as mentioned.

2.11 firmware:

  1. FPGA file works
  2. gcode file works
  3. update.LCD “Unknown file format!”


restart the printer, try again, same result. Info screen shows 2.11 is again in place. Yet still “V4.2.22_LCDH”

This is being done with the original USB stick that came with the printer, and various other sticks formatted in windows as well as with the sd card formatter. The printer is also not able to print ctb files but only cbddlp

it is unknow file format because it has to be in root directory.
we recommend you try again with F2.11.
also make sure you grab the one for Phenom L. it is not the same as Phenom

1 Like

Thank you! I initially had the files in a folder…giving me the same “unknown file format”. Moving all files to USB root fixed it.

1 Like

As a followup, despite having done all the “known to work steps” verbatim and numerous times with numerous USB sticks and computers, I recently decided to give this another shot and the process went through without an issue. No idea why it worked this time.

1 Like