Phenom Ethernet Not Working

Received a new Phenom in the mail last week and am starting to set it up. As far as I could tell, it arrived without any damage from shipping. I tried connecting it to the ethernet, but it wouldn’t display an IP address on the network screen. Restarting the printer didn’t help either. According to my switch, its network card is not functional. Just in case, I checked the cable by plugging it into the computer with the WIFI disabled, and it was still connecting to the Internet. However, it does appear to be able to read files from the USB. Was I shipped a broken machine?

Sorry for the late reply… For the network option it is to send files to the USB drive on the machine, not for operations. Unfortuantely I am waiting on a long enough network cable to connect the machine to it so I can get the instructions sorted for it.

I’d expect that it should at least get an IP address when I plug it in, but the switch doesn’t register anything is even plugged in. For anything else, a light turns on at that connection. I’m guessing the network card isn’t getting power or something similar.

Update: It won’t print either. After waiting for it to complete, there was no cured resin on the build plate or even in the vat for that matter. Nothing to scrape off the fep film. The front screen looked like it worked ok though, but I don’t think the inside screen was working properly. I was able to confirm the UV lights were turning on with each layer based on the light I saw coming out the back.

Did you at least get your cable by now? I could really use some help.

I’ll try some other things in the morning, but I’m guessing there’s a larger electrical issue with this unit.

You could try a dry run. No resin, no build plate, just observe if the screen is functioning properly when in the printing mode. Obviously if the inner screen is not displaying layers then it’s not going to be doing much in the way of curing resin.

I tried printing the large test print file that came on the USB without the vat or build plate in there. When the UV lights came on, I could see a faint glow of the lights coming through the inside screen, but there was absolutely no difference between where the screen should be on or where it should be off.

Sounds like a broken screen or it’s not properly connected. I’m not entirely sure about the situation with whether the phenom comes with an extra screen, but it sounds like contact peopoly support time

I did pay extra for a replacement screen, but I would like to hear from support first before installing it because I suspect that’s not the problem (also nonfunctional network port)

can you go into the tools setting, go to calibration, hit next. a rectangle should come on the LCD screen and allow some UV light through. can you please take a photo of that and include it on here please.

I get an IP address on the Ethernet I/F but nothing I do allows my PC to access it. To send/receive anything. Can only ping it.

Update: Support emailed me a guide to check connections for the LCD. This helped resolve the screen issue. The connections had a piece of foam tape on them which I suspect might have been put on loosely so it pulled the connections apart rather than holding them together. Next, I’m hoping to figure out how to get the ethernet working.

For anyone curious, this worked for me to help fix the LCD issue:

Still need to resolve the ethernet problem. And I’m also curious about why my build plate isn’t centered over the resin vat, which I posted about here: Phenom Build plate is off center

I am also experiencing the same issues with Ethernet. I get an IP address and can ping it, but when I try to write the file to printer through the Ethernet connection I get an error “write aborted”. When I check in the print folder on the printer screen a file shows up but it is blank.
Any solution to this yet?

@mattyb, When your printer is plugged into the ethernet, do you see an IP address in the network screen as shown earlier in the thread? What you see on that screen is all I got when it’s plugged in.

Yes I see an IP address on the network screen

@Mthouve I just downloaded the latest version of Chitubox Version 1.6.3 and I was just able to send a file and print over ethernet.

I figured out why the ethernet isn’t working. The issue lies with the cable that goes from the side of the machine where the ethernet port is to the ethernet connection it’s plugged into. If I skip that cable and just plug my ethernet line directly into the plug on the circuit board, it gets an IP address. Can I get a replacement cable?


Please take the photos and a link to this post and email it to and I will have the developers review this case.

Thanks. I bought a replacement cable from Amazon and the new one works perfectly.