"No Folder" can't read SD cards


#41

will check… So close, build was easy otherwise


#42

Replacement being sent in the end, thanks to the gang at peopoly for the help


#43

So it now detects SD / NO SD perfectly. I used pins and my multi meter to validate that all the pins on the mother board and the daughter board have continuity ( fast replacement is much appreciated gentleman and ladies of peopoly) , still no folder no SD, took the 4gb card, formatted it fat16 in win10, added the gocde file on the \gcode\ folder, still says no folder, no file. Bad SD?


#44

@Stavros_Glezakos

how about a picture of what the screen shows?

this is the best formater to use:


#45

I used the SDCARD formatter recommended here, tried 2g card, the 4g that came with the printer, 16g cards from back in the day partitioned and formatted to 4gb (3.67gb really). One thing I think is definitely an improvement, the hanging on startup is gone, machine goes through it s sequence perfectly. Will take pics when I am home later


#46

we are looking for answers as well. It is usually SD carder and it is fixed.


#47

I checked the connections on the boards individually, let me test them connected so i can verify the pins on one board have continuity with the each other.

I’ll get back to you with videos and photos tomorrow


#48

I appreciate you guys sending two boards, now i see why. One of the cards are too long and won’t sit the pins properly.

The second one

other one is fine, tested all the pins , but the angle is off, so when bolted down it separates them again. Working on a mounting solution now.


#49

I had the same spacing issue. I have not had any reading problem yet.

I put a washer or two under the mount to improve the spacing so it didn’t smash the connector on the board. I don’t remember how many washers but you get the idea. Below is what mine looked like.


Wiring Diagrams
#50

Good idea. Tested it open with me pushing against the board by hand. Confirmed SD CARD works, will try now with washers.


#51

I had the same issue with my SD card board as well. In fact, I was about to write a separate post about it, as I figured it might explain some of the connector failures. In my case, it took two 1.5mm shim washers to level the SD card board to the control board and visually relieve the strain.

Obviously, tolerances on the L-shaped mount, the stand-offs, and the two circuit boards are a problem. I suggest that Peopoly either move to a flexible connector or include a set of shimming washers to avoid the strain issue.


#52

I’m having the same issue with “no folders”. I’ve reformatted the sd card, locked and unlocked it, and created new folders. Downloading “sd card formatter software” recommended in this post. Ok…will be pulling the printer apart to check soldering… see images below


Still can't update my firmware
#53

Are you handy with a soldering iron?

I can see 4-5 bad joints in the second to last picture on the row that’s hard to get to.

Did you read the last 4 or so posts on this topic?


#54

I would if it were my machine. I saw the soldering comments…but I believe my company would prefer to get the parts as they should be without me having to solder them.


#55

Email the Peopoly support address a link to your post with the pictures to get the replacement process going.


#56

Hmmm… I tried emailing contact@peopoly.net It returned with permanent fatal errors on trying to deliver my email…is there a different email that I should be referencing.


#57

Try support@peopoly.net and see if that works.


#58

Thanks! That seemed to go somewhere! :smiley:


#59

replied via email @brianresco
Mattherhackers have the parts if that is where you got them.


#60

I have same problem. This damaged SD card Totally messed up my scheduled…really hoped to get this printing up and running without much trouble but unfortunately i had this problem.