"No Folder" can't read SD cards


#21

I keep having Windows 10 damage the directory data when adding or removing files. Once it’s damaged, the Moai will see the filenames, but they refer to the wrong file data – so I get a print, just not from the file I asked for. Then I have to reformat and recopy the files. I thought it might be the card, but this has now happened on 4 cards from different brands.


#22

I have made my file name short and long and have tried with PM_ at the start and with nothing at start…
no luck


#23

Is it similar to what @ccox describes?


#24

@MR_Potter do you still have the problem.

If problem persists even if you use the original card came with the kit, perhaps it is time to check sd card read (you have to open Moai and remove it from the board). Check out the pins and see they are even and intact.


#25

I have pulled the SD off and checked connections allready.
the first post in forum i found when this was not working was the Un soldered pins on the reader board so have already checked this.
Cheers


#26

FYI to anyone. I recently discovered that the moai won’t display geocode files if the names are too long. So if you have this issue where you can’t find your files, just shorten the name on your computer before hand.


#27

Mark has that in the printing guide.


#28

In case anyone having SD card problem and need to format their SD card, you should used the SD fromatter such as https://www.sdcard.org/downloads/formatter_4/. Especially if you are on Windows 8/10, do not use the standard OS formatter to format the SD card.

Hope this help.


#29

Are you or did you have SD card problems?


#30

how did this program help you? Thanks for the info


#31

I too have “no SD card” error. Removed the reader and no apparent flaws in soldering. Tried re-formatting, downloaded new firmware onto SD card, but it doesn’t recognize it.

edit: unlike my computer the card reader here requires it to be “clicked in”. I wonder how many people have had this problem. Feeling a bit dense at the moment.


#32

gcode has to be in a file directory. Don’t put the firmware in the root directory unless you need to upgrade.
And it also needs to be “clicked in.” You have to insert it upside (metal part facing up)


#33

I ended up completely re-formatting, updating to 1.14 but seem to have lost root directory in the process. Trying to figure out what to do now. This is a brand new build. Everything went together great. Just a learning curve for me. Thanks for the response./


#34

Make a gcode folder and the link below will help with the needed files.


#35

EDIT-
Be careful you aren’t confusing the .stl file with the .gcode file- the way I need to swap between folders and card reader, it can be easy to get it wrong, which I have ;-(
hope this helps!


#36

Yeah, all I had to do was create a folder then it started working. My print failed but i am going to filter my vat contents and relevel and try again


#37

I’ve edit the post with more accurate details…I hope. :grin: Basically, the MS OS formatter may or may not fix a corrupted SD card, but the one from SD Association should always format the card properly. The best option is of course if there is one from the card manufacture.


#38

I actually corrupted my card, my own fault because i didn’t ejected it properly.


#39

I cant get my card to read at all. Sometimes the machine hangs for like minutes before doing the start up sequence and the interface is forzen ( can’t select) . Otherwise I reformatted with the tool above and it can’t find the SD card . Tried many many cards to


#40

if it is hardware issue with the sd card reader, you can remove it and check the pin outs.

some users report fixes by press the sd card slight upward.