"No Folder" can't read SD cards


#1

Hey guys, anyone having any issues reading SD cards? it seemed to work fine on the calibration but i ejected the card and reinserted it and now i get “No Folder” i’ve tried several other SD cards I have in my shop and freshly formatted fat32


SD card (No folder) / (No gcode file) SOLVED!
#2

Updated to the latest firmware using the SD card went good but it doesn’t show the logo for some reason on boot and i still can’t select a folder


#3

Can you check your SD card reader connection, and also check the pin out of the reader (take a picture of it) and post here. Be careful pulling the reader out.

ref: page 33 of installation manual:


#4

working on getting a picture, I was able to update the firmware for some reason but once the screen comes on it doesn’t show the logo from the SD card and no folder’s can be found, double tapping the radial button just shoots me back to the ready to print screen.

Thank you!


#5

I just made the other folder to test but it’s still unable to find any folders.


#6

I took the side panel off and took a picture of the SD card slot, it seems some of the pins soldering came out I didn’t push the sd card in hard and when installing the sd card slot it didn’t seem difficult to insert or anything not sure what went wrong.


#7

I aligned the pin up and reconnected it and she works!, mark can you sell spares? please and thank you!!! will need some soon


#8

i suspected that. lets connect via email for this


#9

Email sent, shes all up and running great now thanks mark hope to get some spare parts ordered! thank you


#10

good thing it worked out. will send extra part next time


#11

I have the same problem. It says “No folder”. One of the pins from the angled header seems broken. I will try to resolder the header but if I dont succeed I need a spare one.


#12

I reflowed the connector and now it seems to work! I hope that if others have the same problem they are able to do the same thing themselves or maybe have some friend who might be able to help! Now its calibrating time!


#13

My SD card reader will not work as well. The card works on my PC to load the Gcode files but the printer sees no folders nor do I get the peopoly bmp file. The reader itself looks okay with no bad solder joints but the solder job on the main board is quite poor and could be the problem. I can’t find my meter to take a continuity reading to know for sure. it does know if there is an sd card or not. if i take it out I get the no SD card msg. but with it in i get the no folder msg.

update: I copied the files from the SD card. Did a hard format in FAT32 and then recopied the files to the card. it worked!!! calibration complete!!!


#14

good, you got it working. were you using the Kingston 4GB card included in the package?


#15

Make sure you software eject the SD card every time if you accidentally just move the card at any point format it no joke, I’ve worked with several people printing with slightly corrupt SD cards and they don’t even know because it’s hit and miss. Most folks seem to just format any brand SD card immeditly before a print.

Mark if you ever redesign the SD card slot in the future I could be completely wrong but a small ribbon cable as opposed to this board to board concept will save the control board from possible wear from usage.


#16

Mark,
It was the kingston card that came with the kit. I just successfully printed the ring. I am now going to give it a go a printing a dental model (main reason I was a backer).


#17

I had the same issue with not finding the folder or files - copy everything off the SD card and format then transfer it back on seems to work for me.


#18

Moai prefers Kingston cards over Sandisk cards. We are still trying to locate i/o issue that pops up from time to time. Users have reported very good experience with this card:

for large print, it is recommended to reformat before printing. sorry about the trouble.

No folder issue sometimes has to do with sd card reader.


Failed firmware update
#19

i originally had the issue with no folder but after formatting it worked and i have done the calibration circle and done both test prints successfully but now i am trying to add my own file i am having no luck at finding my file.
if i format the disk and just add my file it sees folder but no file and if i drop test files back in with my file i see them but again not mine - any idea what this could be ?


#20

I had that problem.