Moai not performing peels again!


#1

I’m about to chuck this machine out the window. Seriously.

I haven’t used the moai in a while, but I have a job that calls for the highest quality. Heck, since it has been some time, I figured I would update to the latest cura as well. I had been running 3.4.whatever for the longest time. I deleted that and got the new cura installed.

Not even sure if that’s the problem, but the new cura, 3.6, might not be ready for moai yet. So I uninstalled that, and then installed 3.5.1, which the internet claims is definitely ready, and they have profiles for it. I did go through and find the couple hidden folders that you are supposed to remove as well before I installed this version.

Installed the new profiles, and modified one to support my resin…basically just changing the speed and the infill %. This has always worked well in 3.4.

Again, not even sure if any of this is even related to the problem…just mentioning it because its something I changed recently. Also, I added supports to my models using chitubox this time, instead of the old ChiTu DLP slicer, which had been my go-to for supports.

I have been testing this for about 3 days, and keep getting crap results. Today, I happened to look at the machine, and saw that it just wasn’t doing any sort of peel at all between layers. I mean, that explains the crap, but why isn’t it peeling?

The machine does do the peel function when you first turn it on, so it is capable of doing it.

Is there something I need to change in the new Cura to get it to generate proper gcode? I changed the printer to Moai, and am using the new profiles.

I had this happen once before, and it seems like it resolved by getting a different sd card reader to save my files onto the sd card with. I’m still using that same reader, though. Formatting the card didn’t make a difference either. I don’t know what to do next.

Help me Obi Wan Community…you’re my only hope!!


#2

Have you tried using Asura to do the slicing instead?


#3

So, I want to, but…

I don’t know how to adjust the laser speed and infill ratio in Asura so that it will work with my resin (Formlabs Black version 4). The info doesn’t seem to be in the Asura documentation either. If anyone can answer this, I’d love to try slicing the file with Asura and see if that changes the (lack of) peel behavior.


#4

Let me get this right, its not doing a PM motor actuation (even at the beginning of the print?).


#5

When you turn on the machine…it does one.
When you first start the print…it does one. One.
Once the build plate is in the liquid, it no longer does any. I’m amazed I haven’t destroyed the vat yet.


#6

you may need to use the SD card format tool they have on the wiki, do a full format with Overwrite option. it will take a while but it will wipe the card clean. this could solve your issue of bad gcode copying or whatnot. give it a go.


#7

I already tried doing a full format of the sd card, though not with that tool. It did not help. I can try again with that tool. I will also try a different sd card.


#8

I assume you have done a complete system reset?


#9

yea, use the tool it does more then just format. make sure you choose full with Overwrite


#10

GIDEONkjv, I assume you mean turning the Moai off and on again. Yep, I do that after every print on principle.

If you mean something more than that, please elaborate.


#11

Sorry, The way I said it was confusing. Basically taking all your settings back to the suggested settings for firmware 1.18.


#12

Other than laser power and bed level height, all settings are at 1.18 norm.


#13

I would take the side off, remove the vat and print bed. Then I would start a simple print (like a basic level rod) and keep a close eye on the PM motor and see if its making noises, clicking, moving, locking up, etc. Basically just see if its moving at all. I would also check all the connection for the pm motor to the board for loose/frayed wires.


#14

it’s seems a problem with the SD card or the SD card reader. Use the format tool @Kagekitsoon suggested or probably better, try with another SD card.

It could also be the card reader. Unfortunately you’d have to check the contacts on the main connector to see if they are fine. Check here Common problems, simple solutions

Also if you are on linux or mac, remember to convert the file to DOS format (yeah… I know…)


#15

Okay, here’s an update:

I happen to keep a lot of my older gcode print files, just 'cause I’m too lazy to delete them. I went and put a known good file from a few months ago onto the sd card and ran it. It ran fine, and the peels happened as they should.

Put the gcode file I recently sliced using cura 3.51 onto the same card in a different directory, and onto a brand new card that I formatted with the sdcard formatter tool from the wiki. Neither of those files functioned when run on the machine…the peels didn’t happen.

I’m thinking there is a problem with the file, therefore, and that probably the cura install is somehow to blame. Gonna try a couple more things.

I’d love to try slicing with Asura…if anyone can tell me how to change the laser speed and infill in Asura, that sure would be helpful! Given the number of people who use a wide variety of resins from different manufacturers, I really have a hard time imagining the program is at all useful without that functionality, but I can’t find it!


#16

Son of a crap. I think I solved it.

After newly installing the cura software, guess what one thing I didn’t restart? THE COMPUTER.

Just restarted it and saved a new test file. It behaved normally.

Free software. You get what you pay for. :unamused:


#17

No, no. That didn’t really solve it. But now I really solved it. I think.

The file I had been running had two stls it, but on the test file I just ran, I only loaded one, for brevity’s sake.

When I tried to do an actual print with both stls in it, it failed again. Ah-HA!

There was a problem with that stl. Something subtle. Something weird. IT was causing this strange behaviour.

I ran the stl through netfabb and tried again. Success!

Man, I usually run all my stls through netfabb at the very beginning, and this time I just got lazy. That’ll teach me.

It’s so strange that a problem with an STL could cause an actual change in hardware behavior, but that’s clearly what happened.

My complaint about free software still stands though…PREFORM from FORMLABS tells you when you load a crap STL and fixes it for you…

AAAAARRRRGGGG!!!

It did 52 layers normally and then quit doing peels again! What the actual hell???!!!

Next step:
I reflashed the firmware, and tried again. I ran a test file dry, with no resin tank in the machine, and it went through the entire file, doing peels the whole time (at least I think, I couldn’t watch every second).

So after that, I put the resin tank in and printed the same file again. It was seeming to print fine, and doing peels, but I had to leave for a while so I don’t know if it did it the whole time. What I do know is the resulting print looked like ABSOLUTE CRAP. There are areas of compression and crappy lines where it makes me think it was failing to peel for at least a while.

Next step…I loaded a gcode file I created a few months ago that printed fine at the time. It started fine, but no. it is not peeling either!

Any ideas anyone? @peopoly ? How do I get this thing printing again???


#18

Sorry for the issue you are having, i get that your are very frustrated about this but it would be easier if we slowly tackle on each problem at a time.

  1. check the connection of the PM motor
  2. Asura pre-set the laser speed in it’s profile, but the laser speed will only affect your print time.
  3. Infill percentage in Asura is in the hollow panel
  4. try a small test print with Asura
    I assume that your setting are fine and the part when you said it stops peeling at layer 52 maybe the connections of the PM motor went loose.

#19

Option 1: it’s a mechanical issue. So you need to check all your hardware, screws, motors and so on. There’s a guide in the wiki, check that out.

Option 2: the mainboard is failing on you. There’s little you can do about it. Lately we found out that the drivers and MCU run pretty hot, so I always suggest to add small heatsinks to the 2 stepper drivers and the main MCU.


#20

I have ordered a new peel motor…we’ll see if there is any improvement after installing it.