Major stretching in Z direction

#1

Forgive me if this is in the wrong section. My new Moai is experiencing some crazy stretching issues in only the Z direction. I started troubleshooting and eliminated several parts of the equation, but cannot pin down the cause.
I’ve been printing with great results for about a month now; haven’t changed any settings or anything. All of a sudden, my models are ending up with major deformities, but only in the Z direction.


Normal ring was from about 2 weeks ago. I’ve swapped FEP films, SD cards, updated Cura, updated moai firmware, checked the tightness of all screws, etc. Any help from one and all is greatly appreciated. It’s like the Z motor is actually moving 2x the distance that it should. Below are the current settings I’m using.

easy to level plate
FEP vat
Firmware 1.18
cura profiles straight from peopoly
test ring gcode was untouched - straight from peopoly


0 Likes

#2

try the DIY-test print, see how the pegs comes out, you might need to re-level the vat

0 Likes

#3

Many thanks for the lightning response.
I did re-level after swapping FEP films; the easy to level build plate sure makes things easy. However, after downloading the DIY-test print straight to the SD card, popping that card into the printer and printing, these were the results.


The smaller one was from the very first print I did; a respectable 10.79mm in height.
The latest print, all 4 cylinders are close in size (within 2 thousandths of an inch), but the smallest one was a whopping 14.52mm.

0 Likes

#4

Hello @ExplosiveD,

the stepper motor and its control as well as the spindle obviously function normally during reference travel. Since the ring and the cylinders have been printed at all, one can assume that the building board drives correctly to the height of 1817.

When looking at the longer cylinder, it appears that the layers have a greater height from about 1/4 to the start. This indicates that the error occurs only after a few minutes after the start of printing (and at higher load).

If you look closely, can you compare the layer heights?

I suspect that the control of the Z-stepper motor is faulty.

The mechanics, the engine and the cable to the engine are obviously not broken, as with bad contact or a “slip” clutch steps would be lost, but no steps can be added.

0 Likes

#5

I would start with reformatting your SD card and then checking the SD card reader for bad pins (cold solder joints, bad connections, etc.). These are a major point of failure with the Maoi and can produce these sorts of printing artefacts.

After that, I would probably look at the controller. However, this looks like a g-code interpretation issue, not a mechanical one.

0 Likes

#6

thank you guys for trying to help out, the cylinders indicates that you need to re-level your vat, let’s start with that first
it’s strange that you said it happen all the sudden, usually the cause for unusual z-size change is that the user for got to remove the previous prints, or having z -reset too high

0 Likes

#7

@peopolysupport: an incorrectly aligned VAT can not cause a Z increase continuously over the printing process!

1 Like

#8

Just to rule out every possibility, I ran out and bought a new sd card, sd to usb reader, and even used a different computer to load the PM2_zring-test.zip file onto the sd card and re-leveled the bed for the third time. Still not good.

.

Here’s a pic of my board; re-seated the connection and every solder joint looks kosher.
I’m running out of ideas for an easy solution. Should I contact Matterhackers, whom I purchased this kit from for a replacement reader/controller?

0 Likes

#9

I think changing the board solves the problem.

0 Likes

#10

let’s back track a bit and so we are on the same page.

so basically, your print becomes taller no matter water you do? The resulting pic showing how the ring printed with pre-sliced gcode would be much longer than the previous one. Is that correctly?

Base on the fact that the print actually completes, it is unlikely there is anything wrong on motors or even electrical boards because your rests would have been much more random than being able to print.

Can you reflesh the firmware and do a Advance Moai calibration :

to just see how the scanning looks. (too big or too small of the circle and etc)

0 Likes

#11

Yes, any gcode that prints is stretched in the Z direction.
Flashed firmware for the 3rd time for 1.18.
I can confirm that center-cross gcode and moai-adv-calib big/small circles match the paper lines exactly.

0 Likes