Issues with Asura3D under windows 7 in Virtualbox


#1

I have this issue with Asura under Windows 7 x64 in Virtualbox which causes the following:

image

Also when I try to open a file or anything it crashes shortly after…

image

Is there any easy solutions to this problem? I’m pretty sure it’s related to some missing drivers but I’m really not sure which one…

Note that I’m running Virtualbox on a Mac.


#2

My guess would be that qt tries do do something that isn’t implemented or blocked in the Virtualbox VM. You can try to adjust the VM settings but i’m not familiar with Virtualbox VM.

Have you tried using Wine? I use Wine to run Asura in Linux and it’s working fine. As i understand Wine is available for macOS: https://wiki.winehq.org/Download


#3

Great idea! I installed it but when it launches I get the following error: https://pastebin.com/xajf5CBX


#4

Hmmmm, it crashes at the same offset (0x2fc200) in qt5gui.dll. Maybe your copy of Asura is corrupted? Try to redownload it and check if it still crashes. If you use the link in the wiki you can download the newest version (Asura 2.21).

If that doesn’t help you can install some other application that uses qt5 and see if you get the same error, then it’s probably a problem inside qt.


#5

@Joe

most of the crashing issues with Asura3d centered around graphic support for opengl drivers. what is the compatiability of the VB with opengl?


#6

Don’t know but I’ll look into it… I also tried with PlayOnMac but it’s the same issue as it’s based on Wine and Wine also failed.

However I don’t think I will spend a lot of time on this because (stop me if I’m wrong) the MacOS version of Asura should come out soon, right ? :wink:


#7

we are working on that and we know we have quite a few OSX users