Help with frustrating layer shifts


#23

i recently changed to a new vat and had the same issues and found that the vat was very wobbly, i compared it to the old vat and sure enough the measurement of the insert was off by a pretty large margine almost .05mm i added some folded paper and taped it to the bottom and slid it in it was a bit tighter but the vat didnt wobbel at all and everything printed perfectly after that.


#24

Today was a very tough day. As I was cleaning out the resin to do the galvo tests I gouged the fep and needed to replace. Ended up with 3 of the bottom screws being totally seized in the housing. Had to get my EZ outs ready, 2/3 came out easier, the third broke off in the housing and I had to go digging. Luckily the hardware store had replacement screws handy. I think my Moai hates me!

Going to put everything back together tomorrow and try the glavo tests and switching the cables.


#25

New FEP in place, this is my galvo calibration. No cable changes, no setting changes. I ran with both the heater and without the heater - same results. Just making sure I’m not missing anything. This looks ok, yeah? Not going to put the side panels back on until I confirm.


#26

Yes that looks ok. Please also do the advanced calibration with the cross pattern in the middle.


#27

Calibrated the galvos and redid the leveling with the new FEP.
A: 10.80
B: 10.79
C: 10.77
D: 10.79

Reprinted my peg experiment:

No better. In fact, maybe even a little worse.


#28

Next step:
Swapped both input and output cables for the galvo drivers (left the power one alone) and reprinted.

AMAZING, looks beautiful, little layer lines here and there but not too bad.

But…

They are all ovals now. I’m so confused.

Help.


#29

Ovals in which direction and how does that compare to the layer shifts you were seeing before? Can you recalibrate after switching the cables? You can probably eliminate the oval effect.

I think you have a bad galvo or galvo board. The shift only appears at the limits of galvo motion, i.e. the center posts look fine. Whichever axis the distortion lay along is probably the bad board. My guess is it is a loose or bad pot. However, if you switch the boards back and the problem disappears, then claim “loose connection” and declare victory.


#30

Do not do a calibration with the cable switched! It will change your normal existing X Y calibration and you don’t need that. When the cables are switched the X and Y direction change and the texts appear mirrored. Also, I think you should try different prints as well, like the Moai sculpture and the ring, prints that came originally with the printer. This will give a more complete view of the issue you may have.


#31

Switching the cables is usually used only for testing the galvo boards. It’s not a solution of the problem. It is only a temporary thing to be used for checking the electronics.


#32

I agree with paradoxical cat I think you need to look into getting a new galvo system.

By the way have you checked your mirrors to see if there’s any chips on them?


#33

I’m getting so frustrated. I think we are getting closer but progress is slow. I switched the boards back this morning and printed just a single cylinder in the front left corner. Wanted something with a small peel force just to further rule out something with the tilt mechanism.

This was the result (viewed from left side):


Not as bad but layer shifts still present throughout, in the front/back axis (which would be left/right in this picture). Cylinder is round.


#34

Reversed the drivers again and printed the same file. Picture viewed from the left.


Worse layer shift but now it’s in the left/right axis! Shape is oval again but that seems like just a calibration issue. So seems like a bad galvo board.

What I’m confused on is why the last time I switched they printed perfectly (except for being oval) but now the layer shift is showing again. Must be something that’s loose on the board. Also confusing is why the layer shifts are so severe on some prints and very minor on others.

Checked the mirrors, they appear clean and this really points towards a bad board.

What do you guys think? Anything that Peopoly HQ can weigh in on?


#35

On an off chance…check the wiring harnesses. Particularly, the connectors. The likelihood points to a loose connection and/or an abherrant signal (I am thinking high resistance), but without a wiring diagram, etc. This is all speculation.

The possibility is that switching the wires may have corrected the bad connection, but since the shifts are random, it could also have been luck.


#36

@geeek204

Sorry that you still have this issue.

Couple follow up questions:

  1. when you switch the cable, this means what was supposed to print on x axis will be swapped to y-axis and vice verse.
    Do you notice the shift is still the same direction or different direction

  2. are you cables all bundled together? some times shift is the result of interference, and bundling power and galvo data cable is one of the potential sources:

http://wiki.peopoly.net/doku.php?id=moai:interference


#37

@peopoly

  1. The shift switched directions when I switched the cables. When assembled normally, the shift was in the x-axis (front to back). When I switched the boards the shift occurred in the y-axis (left to right). To me this reveals that something in the x-axis galvo board or wiring is at fault.

  2. Yes I’ve tried unbundling and rebundling the wires but no change. It was working perfectly a few months ago and then suddenly stopped working so it seems that something broke or is loose on the board.


#38

new galvo board, galvos… :wink:


#39

Tried messing with the cables today and printing a calibration cube directly in the center of the plate.

Lots of layer lines in the x-axis (depicted on the Y portion of the cube), also note the weird artifact inside the X. Not sure what that’s from.

Because of the precision I require my machine is essentially useless at this point to me. Has anyone heard anything from @peopoly or @peopolysupport? I know they’ve been responding to other threads but haven’t chimed in here for over a week. I also sent them an email about a week back but haven’t heard anything on that end either. Would like to get my printer back up and running.


#40

Give matterhackers a call. Reference them to this thread and they will be able to help you out. They carry all the parts for the printer.


#41

It is/was Golden Week in China. Everything shuts down. They will probably respond after the holidays or the catch up the backlog.


#42

Still nothing from Peopoly so I’ve contacted Matterhackers to see if they can help me.