Help with frustrating layer shifts


#1

Need help, trying to use my moai for my dental business. Using HiTemp resin and dealing with some very frustrating (and somewhat consistent) layer shifts.

Please click on image to see full size, as right side is worse (right side equals front of machine in this view).

Seems that problem is mostly concerned with the outer edges of the print bed and get better as you move in. Printed another set the other day and it appears very similar. Have opened machine up several times to make sure all screws were tight, went through moai tune up guide step by step. Sliced in both Asura and Cura with the same results.

Specs:

  • FEP vat with easy level or classic build plate (have used both) - New 100 micron film
  • Most recent leveling with pegs at: A- 10.81, B- 10.86, C- 10.85, D- 10.87
  • Heater installed
  • Firmware 1.18 w/ most recent settings applied. Only difference I have is X size 925, y size 924 based on calibration cube. Laser power set at 50.
  • Tightening down build plate with wrench from moai thingiverse page

Any help is appreciated, about ready to put my head through the door with this problem!


#2

hmm if the layer shifts are in the exact same spots no matter where you put the models on the build plate you may have either a bent lead screw or your vat is wobbly but a wobbly vat would make the shifts random and never in the same spots


#3

What resolution you printing at?

What is print speed?

What is Z-moto setting?

What is PM moto speed?

I am confused at why your x and y size are different from standard settings, since you level the vat with the screws?? I personally never change my x and y settings.

Have you tried doing these with traditional supports?

Have you checked your lead screw to see if it wobbles at all during the whole travel up and down the z-axis?

Which heater are you using and where is it located in the printer?

Has it done this all the time or just with this resin?

Sorry for all the questions just trying to get a better idea of what’s going on.


#4

the cube will not give you any exact measures, this was done by many users.
go back to default settings for X and Y, use this guide for calibration :https://wiki.peopoly.net/doku.php?id=moai:asura&s[]=calibration

we also update a guide for hi-temp resin, you can check it out:http://wiki.peopoly.net/doku.php?id=moai:nexresin


#5

Have you looked at the g-code in a viewer? The shift (if I am interpreting things correctly) is very specific. Is there a corresponding shift on the far side of the model? Does the shift occur in exactly the same place?

If this is a Z-screw problem, it should make a noise with that radical a shift. Is there a loud(ish) click or clunk or apparent binding when the print bed descends?

What is your power situation like? Do you have anything else on the same line? Is the heater a Peopoly heater or third party?


#7

Hi everyone, I am the original poster but my other account got locked when I tried to post multiple pictures. I contacted the forum administrator but they haven’t reactivated it so I just made a new one so I could respond.

@GIDEONkjv
Resolution: 100 microns
Print speed: Default in asura or 85 in cura with new version 3.6 and new profiles
Z-moto: 2
PM moto: 15
Heater is the latest one from Peopoly, I let everything heat up for 30mins prior to starting print.

@Paradoxical_Cat
I tightened everything down according to the tuneup guide and thought I had found the silver bullet as one of the holders on the bearing for the vat was slightly loose. Pt the print after had the same issues.

I created a new test to try out the different variables. I made a cylinder in fusion. 15mm wide base, 1mm tall and a 5mm wide w/ 50mm tall cylinder on top. Sliced in cura, 2 cylinders on the left side (A & B positions), one in the middle, and one on the right side in the middle.

Unfortunately with my new account I can only put one picture in per post so I’m going to upload my first print. Didn’t change any settings from the print I originally posted. You will have to wait in suspense until my account is approved so I can post the rest of the tests.

Looking at this the left side pegs are closest to us and the other two are towards the right side. The front portion of the build place is on the left side of the picture. As you can tell the problem really only exists on the left side of the print bed, the peg in the middle and on the right side printed perfectly, but there are several layer shifts on the pegs closest to us.

IMG_4618crop


#8

One more photo of the print above:


Ok, here’s the continuation of the saga.

Next I printed the same file but changed my z follows to zero as I heard that helped some people.

No dice and the layer shifts are in a different place so I know it’s not the file. Again, other pegs on right side of vat (far side in picture) remain ok.

Next I reset my x & y sizes to the default 900.

Arg, no better.

Finally I rechecked everything internally. I took apart the tilt mechanism as well as double checked all the screws on the linear rails and reprinted.

I’m about ready to put my head through the wall!

The most frustrating part is that I’ve had the machine for about 8 months and have successfully printed with both the grey and the high temp resins in the past. Then I didn’t use for about a month and all of a sudden ended up with these problems. FEP film has been changed 2 times just to make sure but I’m all out of ideas.


#9

Additional Photo


#10

I think you were posting too many pics in one day for new account and the spam filter was activated.

For this layer shift, it is quite a unique kind.

  1. it only happens to one spot, not the entire plate. This suggest glavo or z-axis is not at fault, since it would have affect the entire plate

  2. based on the shape of tilt and as well as your pm motor speed (15 is higher than recommended for FEP) I am leaning. I think the best next step is:
    update to settings here for FEP vat
    http://wiki.peopoly.net/doku.php?id=moai:fep

and give it a go. perhaps I missed it but you also did not mention which spot (ABCD) is the shift. That helps determine potential cause, as AB side (left) has different peel force than CD side


#11

Okay, I know your probably going crazy with this, but to be honest it looks as though that side of the vat has either 1–too much pressure 2–something wrong with the vat. Didn’t you say that you have an easy level build plate? If so I would try to use that and re-level, Check your vat (fdm layer) and make sure it is OK (Maybe even use a new vat if you have it)…

When you re-print change your pm Moto to 10.

The fact that it is only on that one side makes me really suspicious of the vat/leveling issues.


#12

This must be maddening. What I am seeing is mirrored layer shifts, on the left side of the vat along the hinge axis. Is this correct? If it is, then it should not be mechanically possible, because the shift should be parallel, not mirrored.

If what I wrote above regarding the orientation of the problem is correct, then I think the problem may be electrical in nature. If not, then I am stumped.

How is the machine powered? Is there a line conditioner? Are there other devices in the same circuit? Have you calibrated the galvos and watched their behavior?

Edit: in the images of the multiple models filling the build plate, it appears that the artefact appears across the outermost rows. Is this correct? Try printing the posts at all 4 corners of the build plate as close to the limits of the build area as possible. I think the issue is manifesting at the limits of galvo movement. The intermittent nature suggests power issues.


#13

A few important things to check. Is the layering appearing on both X and Y directions? If you swap the data cables for X and Y galvos, how the direction of the layering is affected?


#14

@peopoly
Here is an image of the setup in cura:

My mistake, thought I had the correct fep settings. I changed them and am printing a new plate as we speak, will post the results soon. I think I may add a couple more pegs onto the C & D points to see if it has to do with the corners of the build plate.

@GIDEONkjv
Yes, going crazy! Haha. My leveling pegs are all in the 10.8-10.9 range so I’m not sure how much more I can reduce the pressure before things stop sticking to the build plate. I’ve tried both the easy level plate and have changed the fep twice in this vat but keep getting the same results.

@Paradoxical_Cat
GOOD CATCH! I hadn’t realized that but now the I look back through the pictures the artifacts on the A & B locations are mirrored. Agreed that this makes me think it’s something more electrical than mechanical. I will print another plate with pegs at the ABCD positions and see how it turns out.
As far as power, nothing has changed since I bought the machine 8 months ago and it worked fine. I added the peopoly heater but that was in response to the problems, so they existed before. No line conditioner, the power brick is plugged directly into the wall.

@Raoul
Good idea, I will swap the cables and try again.

Thanks all for the help, will post more results soon.


#16

My first guess was the heater, but since the problem existed prior to it installation, that is less likely. I would try a line conditioner, if you have one (a computer UPS, for instance) or a different power plug. Another option is that the power supply has gone bad. If you have or know someone with an oscilloscope and electrical test equipment, then you could test the unit. Alternatively, if you know someone with a Maoi, you could swap supplies to see if that solves the problem. After that, it’s a long hard look at the circuit boards…


#17

Most recent plate printed. Corrected all my settings to the fep ones. Changes were: PM speed 15->12, PM Reset 40->60.

This is the result:

Better but not usable. Still very symmetric errors.
This is the same print but from a different angle, as you can see the pegs on the right side of the printer are still coming out very nicely.

Printing another one right now with pegs at all four corners to see what that will show. After that I will switch the cables in the galvos. If no resolution from that I’ll take Paradoxical’s advice and see if I can get some filtered power or a different adapter.


#18

Printed with all 4 corners, appears that the problem is associated with the laser scanning at the far extents of the travel.

Cura layout:

Result (viewed from left side):

Viewed from back:

Problem still exists with layer shifts occurring from front to back of the machine. (X axis?). I am going to swap the galvo cables but I’m past believing it is a mechanical problem at this point. Definitely something in software or in the galvo drives. Seems interesting how reducing the peel speed helped though, that doesn’t make sense if it’s a problem with the electronics…

Anyone have any ideas? I will try and reprint either this weekend or next week.


#19

It may be a power issue, if the peel motor were drawing extra amperage… however, this is for Peopoly’s engineers.

I think that switching the galvos controllers will be informative. Have you calibrated them?


#20

Yeah I would be interested to see If everything is normal on a galvo calibration (circle test).


#21

I know your probably getting tired of printing the same stupid bars over and over again, but was wondering if you could do a few things…

AFTER doing the circle test (if everything is in order)… could you try using a completely different SD card (if you haven’t already). If its still doing it with a new SD card, could you print another one with the corners moved into the middle of the build plate about 3/4"

You see, to me I am trying to look at all the variables here and there is one thing that is consistent that rules out a lot of other things–the sides and middle are fine! This is really important for narrowing it down because if it was a, z motor, pm motor, etc. usually it is uniform across the whole print. This is generally true of heater and electrical abnormalities (learned this from my own experience). If a heater, or electrical glitch was present than you would 99% chance see it in the other pillars and it would be more uniformed instead of mirrored.

I personally believe with about 98% certainty that the issues lies within the galvo/plate calibration, and or alignment (which COULD be related to electronics) but the fact that the quality changed dramatically when you made the settings more “aligned” with the qualities of an FEP vat cant be overlooked. I have seen these exact same shifts in other threads and they were fixed with a new galvo board, but their shifts were all the same direction everywhere on the plate.

So, doing the galvo data swap is the most important at this point, but then I would like you to try the few things I listed at the beginning of my post.


#22

Hey

Have you checked for dust on your mirrors and or protective glass?

Just a random thought to add