Failed firmware update

My printer won’t boot after firmware update.

Trying to update the firmware to 1.15, I followed the guide at https://peopoly.dozuki.com/Guide/Moai+-+Firmware+Upgrade/3. Since the guide said that SanDisk cards did not work, I didn’t use the SanDisk card that came with the Moai. Instead I used another card I had lying around. After checking that the card was formatted with FAT32, I cleared it and added the files from the zip (not including the changelog). After inserting the card in the Moai and turning it on, nothing happened. Not knowing how long it would take, I left it alone and did other things. After ~3h the screen was still black. I came to the conclusion that if it hadn’t finished by then, it probably never would. After turning it off, removing the card, and turning it back on, the screen no longer lights up at all.

Does this mean that my logic board is bricked? Is it possible to get a replacement?

Also, please update the guide to say that the card that came with the printer can be used for the update even if it is a SanDisk one, if that is indeed the case.

It should only take 30 seconds to a minute.

I don’t think I’ve seen this happen before or at least posted on the forum.

Try the formatter linked below. Use the Overwrite function and try the firmware update again. If that doesn’t work try the card that came with the printer.

Then report back.

That actually worked! I did not expect that after having tried several times before with both the card I tried first and with the card that came with the printer. Now I tried with the formatter, both with the card that came with it and the one I tried first - the former one failed but the latter actually worked.

Thanks a lot. I’m glad that I don’t need a replacement logic board after all.

1 Like

Can you post a picture and the info for the one that worked and I guess while you are at post the info and picture for the one that failed also.

OK, I’m afraid I don’t have much info about them, and I’m not sure what info you want.


The one on the top with the “Moai” sticker (added by me) is the one that came with the printer. I’ve had no problems with printing off of it. Updating from it failed both before and after using formatter.
The one on the bottom is the one that succeeded in the end, but only after using the formatter.

1 Like

Does the formatter report the technical information on the card, specifically the controller? (I am amongst the lucky and have not had to do anything to my card.) If it does, you might compare the reported chip against the manufacturers’ specifications. There are a large number of fake SD cards out there, even in legitimate channels. And, they are very hard to spot without checking the hardware.

No, it does not show any technical information other than size and file system information.

That doesn’t look like our card. @kathanon Where did you get the kit from?

Moai (and many 3D printers) are picky with SD cards. Sandisk never seemed to work for upgrade firmware for reasons beyond us so we only ship Kingston card.

I was a backer on the Kickstarter, and got my kit that way. I might plausibly have switched what card I used with the Moai before labeling it, but I don’t think that I did.

Looking at the comments on the firmware update guide (https://peopoly.dozuki.com/Guide/Moai+-+Firmware+Upgrade/3), you can see:

it works with the Sandisk we included and generally works better with Sandisk bran SD card.
Shu Peng - 11/10/2017

Isn’t that one of your staffers?

Shu Peng - Isn’t that one of your staffers?

hehe… that guy is all crazy talk! Don’t listen to him! :slight_smile:

I just went through all of this and the flash still failed. I am still on v1.14. Tried 5 times now. Same results. Multiple SD cards.

2 days now and still unable to get this printer working. This is getting a bit frustrating. I am going to bed now. Feel free to try and help me all you want. In the morning I will go to work, so help me then too please. Just make sure when I get home I don’t get any help because that would really suck.

I think this is a clarification on the post. Shu is Mark. As this post was from September 2017, I think that the datestamp on the Dozuki post is incorrect.

Also, IIRC, at some point Mark reported that Peopoly was having significant issues with counterfeit SD Cards being sold to them by their suppliers. It is a common problem.

You can use the printer with v1.14 until you can try one of the recommended cards.

If you can, take a picture of the cards that you did an overwrite format on that didn’t work.

Just to add to Lyndondr’s post: take pictures of both sides of the SD card. Counterfeit cards are often mismarked: usually with a phony label, fake hologram, or incorrect/missing serial number. However, good fakes, like good art forgeries, are hard to spot.

I just drove all over my home town (about 60 miles of driving) gathering up all the SD card varieties I could find. I found 2 that are different than what I had. Neither worked. So I am at a loss. I have tried Sandvik SDHC, SDXC, HD1, various speeds, Kingston (came with the printer), Lexar, and PNY. I have tried cards that were made years ago when SD first came around to brand new ones. All legit cards. I even borrowed a couple from a friend. I have tried formatting quick, full, using SD Card Formatter, using EaseUS Partition Master, etc.

I would be printing with 1.14, but the guide was telling me to set settings that I can’t get to without the firmware upgrade. I don’t know anything about SLA printing, so deviating from the specified instructions is not something I usually do with something I know little about. Especially with something this expensive.

Even so, I have little faith I am going to find an SD card that will work considering the gamut of cards I have tried. So unless Peopoly is going to send me a replacement board with the firmware upgraded I am about done with this printer.

looks like a typo.

we clarfy by saying there is a Sandisk card doesn’t work:

image

before any of that, can you format SD card with
SD formater

the load the needed (all 3 files in the zip disk). give us a screenshot to show the content and try again.

if it is a board problem, we kept extras with Matterhackers and they are your direct contact for support since you are based in the US. They will take care of you if needed.
.

btw, you posted saying you have 2 days without support. could you elaborate on that so we know who you contacted and that you were not able to get support?

By that I mean I have emailed Matterhackers. Scott there has been responding. But I am at work when they are available to help me. When I get home is when I am trying to get this resolved. It’s not their fault. But some type of 24/7 support would be helpful. The emails have all been the same. Asking the required questions to make sure I am not an idiot. Nothing yet has been of any help because of Scott first verifying I am doing things correctly. I have spent over $100 on SD cards since yesterday (cards that I will never use). And as stated, I have tried a number of formatting options.

I have been playing with computers since the 70’s by the way. I have been a CNC machinist for 25+ years. I know my way around this type of tech. So if that helps get the formalities out of the way, let’s get on with diagnosing this problem.

You are wanting a screenshot of what? the 3 files on the SD card?