Endless problems with processing gcode from the SD card

I’m hoping to get a reply from someone from Peopoly, because the problems I am having with my Moai 130 (firmware “SLA-125 V1.18”) are causing a lot of frustration.

Here I have a potentially great machine and the investment over time in the machine, resin, spare parts, alcohol and additional tools has been well over 2000 euros.

But now:

  • often it won’t read an SD card at all: “No SD card”
  • or shows a folder name from memory, but when you try to step into it, no files are actually found there
  • or it starts to print a file, but then the laser stays off and all it does is uselessly move the vat up and down
  • or you select one file and it starts printing another

I have installed the replacement SD-card reader-board which I received from the dealer in Poland, after I repaired the original one after the well-known solder failure. But now both are appearing to give problems. Or is the problem now in the controller?

And in general: what’s up with the instructions to regularly format the card, turning the machine off and on between prints, and never replacing a file on the card but only adding them. This sounds like a serious problem in the operating system / file system manager that should have been resolved quickly after the launch of the machine years ago -either with new firmware or by sending out controller-board replacement-. Has something been done about this in the meantime that I don’t know about?

Considering that it’s unlikely that the problem lies with the power supply, galvo drivers or display panel I am hoping that the manufacturer can send me a replacement controller board with SD-card board. Or would re-flashing the firmware have a chance of improving things?

Please help so that I can become a happy and proud user of the machine again!

Ok, so trying to flash the firmware with a doubtful SD-card reader was a bad idea on my part… Now the machine doesn’t start up anymore. The power button turns blue, but nothing else happens.

How can this be solved?

We are sorry to hear your issue and we have assigned an engineer for your case. The engineer will follow up as soon as they have a chance to review the email. Our technical support team is based in Hong Kong and normally works 9 am to 7 pm local time. Thank you for your patience and we will follow up shortly.

Hopefully peopoly can sort out your other issues, but as far as selecting one file and printing another, the moai has a long standing problem of not being able to handle an sd card with more than one file properly. I’m pretty sure they haven’t fixed it in v1.2 either, so best practice remains formatting your sd card before putting a print file on it and only having one at a time. The rest sounds really abnormal and could very well be an sd card reader issue (the original sd card slot had issues but I’m pretty sure they haven’t shipped those in quite a while).

As you’ve mentioned, this seems like a problem that should have been solved a while ago but it hasn’t, and probably won’t be as it appears the controller board is already at its limit in some regards and the firmware dev has moved onto other work and only works on the firmware occasionally when peopoly needs it.

Good luck with your issues.

Hi Jeby,

Thank you for your feedback and well wishes. I feel a little bit less alone with this now.
Hopefully Peopoly will be able to provide a solution soon.

Hi @Lexiglass,
The “no SD card” problem that happens from time to time is most likely the pins are badly soldered, as you mentioned.
Is your replacement reader the old model or the new model? the new model has an extra cable to make sure this does not happen.

The firmware kept ghost files of the gcodes while it’s printing for pause function, but some times this does not get erased and it just continues the gcode. The common solution is to re-format the SD card after each print, so far we are still working on this bug

Hi @peopolysupport,

I have to give kudos to Pawel from 3Dpartnershop where I bought my printer, he gave me a good tip: to try again with a formatted SD card with the firmware on it.

Initially this was not successful. At that time the old cardreader-board was still in the printer, the one I had repaired earlier. When I replaced it several months ago with the new model, the one with the cable, it was still functioning, but apparently now it is giving trouble.

So then I went to install the new board again, and I noticed that this had a problem: the cover had come loose because a strip of copper from the PCB -apparently the only form of mechanical mounting that is applied, surprisingly- had come loose, see the pictures below. This would explain bad/intermittent contact and data transfer, I would guess.


I made provisional repairs using hot glue:

I put the SD card with the firmware into the printer again, started it, waited… waited… almost gave up again… and then it booted, hooray!! :slight_smile:

Would it be possible to send me a replacement SD-card board of the new type, in case the repaired one gives up on me?

Thanks for help in any event.
Best regard,
Lexiglass

we can’t just send out things just in case, if it does get failed again, please order from your nearest reseller

While I would ordinarily agree 100% with the idea that a company should not send out parts just in case something fails, in this case I would like to point out that the part has already failed and the only reason the machine is functional again is due to my amateurish fix…

So, seen in that light, sending a replacement for the defective part would not be that strange.

Also, even with that, I’m happy to go to a reseller to order a replacement since it should not be too expensive (right?), but I don’t know of any that offer this part on their website. Can you point me to one?