Consistent layer shift


#41

Sure thing. Do you want just the hollowed version or with the supports as well?


#42

the original file with no supports, then post a screenshot of cura to see how you print it (and how many supports you have)


#43

here’s the original model https://drive.google.com/file/d/1oPiDJ1cFtc80uupses676SUhwOD5eWMa/view?usp=sharing

This one isn’t hollowed, just in case you wanted to try something with it.

Image from Gyazo

Image from Gyazo


#44

@matt3o I did another test of a simple cylinder tapering towards the top. about 130mm tall.

Layer shifts start at around 67mm. Each shift is then between 8-10 mm.

This was sliced at 80 microns.
The mark on the front was me marking on which part was facing the door

Any ideas?


#45

there is definitely something off, it can’t be the galvo since the shift start at a certain height. It looks like something with the Z axis. You said you checked all the screws, maybe the lead screw…

Your 3d model seems fine I can’t see any problem with that, I haven’t tried yet but maybe the orientation could be better. The last picture you sent seems to have some slicer issues though. Did you use cura 3.5 with the latest profiles?

Hopefully @peopoly can chime in on this.


#46

I’m gonna have to call iMakr.com tomorrow and see if they can send out a new z axis then. I’ve started another test with the galvos switched over to see what happens, but I doubt it’ll help shed any light on the problem.

I always get those red spots in Cura (i assume that’s what you mean when comes to the slicer issues), in every version I’ve tried 2.whatever it was, 3.4 and 3.5. I installed the latest version from the website and then imported the profiles you linked in your 3.5 post.

Peopoly haven’t added anything useful to my thread thus far, I’m just going to contact the retailer and hope they have parts that don’t need to be ferried over from the other side of the world.


#47

the red areas in Cura are those that need supports. But don’t mind them, it’s mostly for FDM printers. The issues I see are on the last cylinder you printed, but I could be wrong the picture is a bit low-res


#48

I switched the galvos and looked at a test this morning and the shift is in the same direction as it was before so at least I can rule the galvos out completely.

The shifts were closer together though but still started at a similar height.

I also fixed the images in the previous post, should be able to get a larger image now.

I’m going to see if I can get a new Z axis sent out.


#49

I would wait what @peopoly thinks of this issue. Maybe he’s already seen something like this.


#50

They haven’t replied to this thread after 50 posts and just over a week of it being being in the 5 most updated threads, so I doubt we’ll see anything from them now.

I’ve contacted iMakr anyway, hopefully i’ll get a response from them


#51

This is getting fucking ridiculous @peopoly @peopolysupport
Imakr.com can’t even get in contact with you and all I got from your email was saying you’re scratching your heads. I am so sick and tired of having a useless brick sitting and doing nothing, you might as well be scratching your asses.

I’ve already emailed iMaker.com telling them that if they’ve not heard back from you before the end of the week and if a solution isn’t on it’s way to me then I will seeking a refund.

Get your shit together


#52

bendouglas86 , you truly right.
Peopoly should understand that bad support will harm their sells.
The bussiness model of selling a machine and leaving the responsibility of “solving problems” on the solders of the great people of the forum will not hold for long.
Post it everywhere (peopoly facebook , other forums . . . )


#53

@bendouglas86 What you are having there is quite a unique case, and without the electronics, in hand, it is quite hard to determine. Nevertheless, we do not abandon our users, and there are tons of cases here in the forum and the group. Even when emotions run high and some issues are not as easy to find the solution, they would not deter us from supporting you and try to get you back to printing. We have spoken multiple times via email, and there is a cache of parts on the way to iMakr that we sent to support its customers. We will use what is there to see if there is a quick solution for you.

Most the users have directly contacted me one way or the other from simple pre-buying questions to technical support. You are free to ask any one of them here on the site to see if we have been consistent with our support. But all that wouldn’t make a difference for you if we could not get yours working. So I think I got another of your email waiting for me after I landed and we take care of that first?

@Zipory We have exchanged emails few times, and we are working on the distortion adjustment and have been open about what it is in this forum. So to suggest we ignore you is not exactly a fair statement.

@peopolysupport


#56

Forgot to come back and post the results of troubleshooting. It would seem it was interference that was causing the shifting for me. As an experiment I wrapped the heater in aluminium foil and left holes around the intake and output vents. Looks like the waves were caused whenever the heater turned on or off, hence the consistency. As I had it mounted higher up the back panel of the printer it seems the build plate shielding the components enough until it got to a certain height, allowing the EMI to effect the components after about 6.5cm of build height.

Hope this helps anyone in the future. Easy to test using some foil. It’s surprising the amount of EMI that foil can prevent, 1 layer should be enough or you can double up.


#57

thanks for the feedback, does the Peopoly heater has the same EMI effect?


#58

After some experimentation I found that I still get interference from the Moai heater, but no where near as bad as before.

I’ve since taken the step of implementing some shielding around the components in the base of the printer. I’ve surrounded the galvos and galvo controllers with steel mesh overlaid with EMI shielding. I’ve also wrapped the EMI shielding around the heater, the z motor and the peel motor to further reduce any potential interference from moving parts.

So far this proves to have helped out and I’m getting clean prints.

Hope this helps anyone else.


#59

In fact - completely disregard this, the interference is still present. My galvos must be overly sensitive or something. There’s definitely something wrong on a hardware level.


#60

I’m curious if you’re still having interference issues. Is it possible the issue is due to the incoming power differentials when the heater turns on? Do you have the heater and the printer electronics plugged into the same circuit, and not isolated from each other in any way? The quality of power coming to the boards may be different when the heater is running vs. not. If it were me, I’d plug the printer into a UPS with emi/rfi filtering and leave the heater on a regular plug. I’ve seen plenty of sensitive electronics going wonky in odd ways due to small power flucuations.


#61

I eventually found that it was a faulty main board that Peopoly originally sent out to replace my original one in case it was faulty.

My old heater setup was what was causing the interference in the first place and layering foil over it helped reduce it. But along with the heater I was sent a new power board and new main board and SD card reader (the SD card reader was dead on arrival, unsurprisingly). So I replaced the power and main board with the new ones and used the Moai heater. The interference was still there. I got a UPS all set up and shielded the ever loving crap out of everything inside with mesh and EMI shielding materials and it made no difference.

I decided to put my old main board and power board back in as a last ditch effort and turns out it was one or the other that was causing the issue.
Still, I’ve left all the shielding in place and now i’m getting interference free prints. No idea which of the boards (power or main) was the real culprit, but I’ve given up caring at this point and am happy the machine is just working.


#62

thanks for the feedback. It could be the power board perhaps. Not suggesting you pop the old one back but that is likely the source of interference and not the main board