Can't print my own gcode

#1

I know that there are other posts with this same question, but none of the other threads have anything that would seem to handle my issue. I went through a huge amount of calibration prints to get (measurements are below), but I feel it is as close as I have the patience for, especially in light of the fact that the FEP vat is supposed to have better forgiveness. I had wanted to get a little more precise on my dimensions, so I tried to print the x-y asura calibration file, but it did not print anything at all. I brought it into Asura, and made sure to check it was oriented well…but nada. So to check my sanity, I redid the four corner post test…it came out great. Downloaded a file from thingiverse that did already had a gcode file. It printed, but the print was not perfect, because it seems like there was too much surface tension on the peel.

I should also mention that because of the way the documentation is a little all over the map, when I was doing the four corner calibration, I had the z-reset on 1817, and I have been printing with the same z-reset (1817).

I printed out the ring test file, which also is a straight from the web gcode file. So it must be something with Asura. I am on OSX, but the details are below for my setup.

Room temperature (best to be >25C):75 F

What type of resin: Grey

Build plate type: Standard 1-piece

Vat: FEP vat

What type Vat: Peopoly Original vat

Leveling measurement:

A - 10.65mm
B - 10.75mm
C - 10.71mm
D - 10.82mm

Firmware version: 1.18

System Setting is default per Peopoly recommendation? Yes

Laser Power: 58

Z-reset position: 1817

PM Motor Speed: 11

Z Follow Speed: 10

Software used to slice? Asura 2.2.2 - I am using none on the calibration dropdown and Peopoly Moai 80um 35 for the profile

If using Asura,what version and profiles

0 Likes

#2

Here are the files that I wanted to print from (from the meshmixer output, to the b9creator support adds, to the Asura slice)

Meshmixer STL output: https://drive.google.com/open?id=1GSabAwDFfdupUVMgYOJ7sj0Ve4AtTl_P
B9Creator Supports: https://drive.google.com/open?id=1OYgBzqClsQnRhgu1XFSpGLNBXhymEtxB
gcode: https://drive.google.com/open?id=102QrbFshtUCFLhxlKJqZydlsItiVcIeo

0 Likes

#3

I am reading through all the forums trying to resolve my issues and I am seeing more and more that there seems to be firmware issues:

  • The Mac “\n” instead of “\r\n” is not a Cura issue its a firmware issue. The firmware should be able to handle both use cases.
  • That guys are having to reformat their SD Cards to get prints to work points at weak Fat16 code in the firmware. After many SD Card loads I was seeing what looked to be file name crossing.
  • The LCD screen highlighted text not being highlighted until cursors movement is an issue, although minor.

A nice firmware improvement would be to improve how the bed plunges into the VAT. It would be an improvement if the bed started its slow down as it reached the top of the VAT along with having the VAT tilted as the bed enters the resin. This would do wonders on trapped bubbles along with greatly reducing the forces on the bed and VAT figures and mounts.

I am seeing that many of the issues involve Mac computers. I too am using a Mac and am having every symptom that I can see on this forum, after having many successful prints (about 15-20). Now I cannot get any of my prints to succeed. I can go back to the the test ring and it prints just fine, but every trick I read about here fails. The symptoms I am seeing are:

  • Ever rising bed.
  • Laser goes erratic (some code files).
  • Laser does not go on and the vat keeps rocking without enough time to print the layer.
  • The support bases print but then the print fails.

I have not modified any of the default settings. I have left the Cura settings as recommended. I added the \n to \r\n search and replace. I have reformatted the SD Card but nothing is working that was working… unless I print the test ring.

In looking for a better slicer I tried Cura on my filament printers and at times, on a Mac, it would generate bad code. Because of this I always went back to Slic3r. After all my attempts at solving my failed print issues I am wondering if there are Cura issues as well.

Has anyone been successful with any slicer other than Cura? I so could you pass along the setting that you had success with your prints.

I just want this beautiful machine to work reliably. I would be interested in hearing what other Mac users have done to get reliable print results.

1 Like

#4

I ended up finding the workaround I needed! I am using the homebrew unix2dos fix to get my gcode to print! It was best to follow the instructions from @Hypergyaos (although I had to find alternative directions to loading homebrew…that was ultimately the fix I needed to get going).

Any word on when Asura for mac will be able to compile dos code directly?

2 Likes