Build plate doesnt lower

Hi guys,

I have been printing fine, on .18 firmware. Now I wanted to starta new print, sliced it in Asura, and tried printing.

Plate doesnt lower and No laser.

I have tried reformatting the SD, and reslicing. Doesnt help .

Then I tried printing the the test ring with all the small holes. Blate lowers a couple of CM, then back up … No laser nothing.

Then LCD suddenly doesn’t turn on every time I turn the machine on.

The printer is a 2-3 of months old.

Any ideas ??

Hi @cali3d i believe you have posted this on fb and it got solved, yes?

Yes, sorry I got this fixed. :smiley:

My issue was that I formatted the sd card, and copied the original folder back onto the card.

When I formatted the SD card, and created the Gcode folder manually, and then copied my file onto it, it worked again.

I am not sure about the LCD display issue though, since it has been printing :stuck_out_tongue:

you can check the pins of the LCD or check the connections, you are printing fine so i think it would be an easy fix