Asura software - Updated 12/29/2018 Undo, Save Project and Z-axis cross-section


#263

Hi there,

A quick bit of feedback on 2.2.

I imported a model, added supports, then realised I could also use some space to add a second stl file.
Test 1:

  1. Import the first model and move to position
  2. Add and edit supports
  3. Import second model
  4. Select second model only.
  5. Use the handles to move the second model.
    Result: the 3D window froze 100% of the time.

Test 2:

  1. Import the first model and move to position
  2. Add and edit supports
  3. Import second model
  4. Select second model only.
  5. Press the centre button. This successfully moves the second model to the centre of the build area.
  6. Use the move handles to move the second model.
    Result: the 3D window froze 100% of the time.

The top menu is still accessible even though the main 3D window is frozen. Attempting to reopen the saved project file causes the whole program to crash.

I’m happy to send you the files if you’re interested.

Apart from that, I’m really happy with it. :slight_smile:

cheers

Jason


#264

Sorry to double-post.

On a similar issue to JackyBoy, I imported the model, auto-generated the supports. I then added and deleted supports manually. Saved the stl file then saved the project. Closed and then re-opened the project, and it looks like I’m back to the point where I pressed the Generate button. The manual editing work was lost.

Then pressed the New Project button and the program crashed.

On a positive note, the stl saved correctly with the manually amended supports.

cheers

Jason


#265

thanks for the feedback. Can you email the file + log to asura@peopoly.net ?

paste in the message will be very helpful

thanks again for the feedback


#266

I tried to search this forum post but was having a hard time finding my issue. I am trying to make a mesh 100% solid but every time I move the slider from 50 to 100 and tell it to update or press okay the program crashes giving me a not responding notification. This has happened on multiple computers.


#267

I am getting this error actually:

Capture


#268

the mesh is solid at 50. It is just how accurate it is. Since it is internal part, you don’t need the accuracy to be high and 50 does good enough job and is very quick


#269

Hi there, hope you got the files. I’ve realised that the easy way to get the error is to just import a file, add supports, import another one, and then try to move it. I’ve had it happen to another couple of imported stl files that don’t otherwise have a problem.

Edited to add:

I’ve been able to replicate this using one model. Import the model, add supports, try to move the model using the handles.

A second one, in Blender it’s possible to create an empty 1kb stl file by mistake, which causes a couple of problems in Asura. I’ll forward that file to you too.

cheers

Jason


#270

thank you. this is very useful for tracking down thebug


#271

Found something odd.
I am able to open the linked file in Asura 2.1.1 but it will no load in Asura 2.2.1
https://1drv.ms/u/s!Atb9AjLhaVxXi99Fhqonya_p9ofbiA


#272

Just got enough time to play with Asura 2.2.1 custom calibration,
As far the formula with nominal and measured value is PITA to calculate 24 times made simple excel file
https://www.facebook.com/download/287371785290542/moai_asura_calib_calc.xlsx?hash=AcquUxBprIxsiNcD


#273

Calibration done.
I did entered measured and the correction values.
Printed the same file again this time with the new correction and the result is : WOW
All measurements within 0.02 of the nominal , except 61 and -61 on both axes , that is within 0.03.
Boy I have some older CNC metalworking machines that are in the same precision range


#274

here is my calibration file for reference
X-Direction
Xval -61 -60.82
Xval -51 -50.82
Xval -41 -40.84
Xval -31 -30.88
Xval -21 -20.94
Xval -11 -10.96
Xval 11 10.97
Xval 21 20.89
Xval 31 30.81
Xval 41 40.74
Xval 51 50.75
Xval 61 60.80

Y-Direction
Yval -61 -60.67
Yval -51 -50.68
Yval -41 -40.71
Yval -31 -30.76
Yval -21 -20.85
Yval -11 -10.9
Yval 11 10.9
Yval 21 20.8
Yval 31 30.68
Yval 41 40.61
Yval 51 50.62
Yval 61 60.65


#275

I have tried 2.2.1 now, and had it generate the gcode to print the same Ring model I had the supports sliding off the side with. this time the gcode only contained the supports… no model the print!..
Peopoly, when you are back from holiday, let me know how to send you what you need to replicate this…
I’m using Cure 3.6 again so no calibrations for me yet… I hope to get my machine working well enough to print nice round cylindrical tubes and gears etc. as well as other more mechanical tiny parts.


#276

I printed a calibration cross without any distortion compensation and these are my values. do they look typical? (I have my X size and Y size set to 918 BTW, I may put them back to 900 and run it again default)

X
-61.2
-51
-40.96
-30.84
-20.84
-10.85
11.06
21.13
31.25
41.45
51.75
62.1

Y
-61.8
-51.6
-41.4
-31.25
-21.1
-11.02
10.95
20.96
32.06
41.2
51.4
61.5

I also measure the cross distance from edge to see how centered I am on the build plate.
X- 4.56
X+ 1.9
Y- 3.2
Y+ 3.4
not bad left to right! :slight_smile: could use a bit of adjustment front to back…


#277

For sure go 900 and print no compensation with asura
Then make your new calibration file and print again with it


#278

this thing is… I keep having issues with Asura messing up my gcode for prints. shifted supports or missing models. so I don’t even use it to print yet, just Cura…


#279

This way you miss the option for corection
asura works great for me


#280

I can’t generate gcode some several of my models without issues… no clue why yet. they work just fine if I output to STL. but when I go to gcode directly I get No model, just supports, or supports not where I put them but all shifted to one side off the edge. strange I know.
I suspect it’s because they never test with models Flat to the build plate. most people do the 45º and such, but sometimes I feel flat but lifted with support is better for some shapes? like this one.

IMG_6196


#281

you could send me stl and will try to slice it for you


#282

here I will share it on dropbox and anyone who wishes to play with getting it to print accurate and clean in Asura directly can have at it. :slight_smile:

I’m open to being wrong about printing this with the flat side away from the inner ledge parallel to the print bed, with a ring of supports around the bottom to lift it up to eliminate cupping.

(and I will create a new Printing advice thread for further discussion if needed)