Advice/help needed: consistent layer shifting

#1

I own a Peopoly Moai for about a month now. The building process was stress free and I had very few failed prints since then, but I have one problem and I’m all out of ideas. Printed models have very visible layer lines/layer shifts and this is problematic for the kind of models I want to print and the reason I bought a Moai. A weird thing is that these lines are reproduce-able, happen at the same height when the model is printed again and I think (I’m not 100% sure) they are also at the same height when comparing different models.

The tilt mechanism has no play and the metal rod is fixed in place. I had some movement in the tray at the beginning but print quality was the same even after fixing it. I HAVE some (very little) play in the mechanism that holds the Vat(not the Vat itself), but as I see it, this stems from the leveling springs and I have no Idea how I would fix that. Tilt motor screw is straight and inline.

I spent about a month now trying to find the source of the problem, I have a hunch that there could be something wrong with the Z-axis, but I also have no idea how I would test it. I already wasted about 700mL of Resin in attempts to solve the issue. So it is starting to get pricey.

Does anybody have an idea how I can diagnose my Moai or even fix?

Examples of the artifacts, you can see the layer shifting also at the support pillars:

_

This the kind of model I want to print and what I used as a benchmark after trying something. Every 3rd time I would print bigger and different models as an extra control. I can post more pictures if needed, I also printed a few of the homer gcode file from this forum (link further down) and other bigger models with the same outcome.

Info:
PP Grey Resin and PP Black
Standard settings, firmware 1.16
except Laser-power: 55 (58 with Black resin)
Temperature about 26°C
Latest leveling: A 10.72mm; B 10.73mm; C 10.74mm; D 10.72mm;
SD Cards were formatted with official format program and many different were used to see if the error was with the card

Software:
Standard Cura profiles (Downloaded 19.03.2018); “Cura-2.6.2-14-Moai Edition-win64”
Supports mostly via Chitu but also XYZ and B9

What I already checked/did/try and the effects:

  1. Tightening the bolts mentioned in the Wiki under regular check up → No change
  2. Tightening all bolts systematic → No change
  3. Checking the build instructions against my build → Everything in order
  4. Re-centering the Resin tank → No change
  5. Fixing the Vat fit with paper and then tape → No change
  6. Tightening build-plate and printing spanner for it → no change
  7. Raised temperature via reptilian heater pad to 29°C (28°C Resin temp) → No change
  8. Tested different Vat → no change
  9. raised Laser-power to 60 and then lowered it to 52 → 60 over-cured, but no change
  10. Tried with 2 different Resins (PP Black and Clear) → no change
  11. Leveled the table the Moai is standing on → no change
  12. Bolted the table to the wall → maybe slight change but hard to say
  13. printed feet for Moai and leveled it → No change
  14. printed flexible pads as shock absorbers and anti slide measure for Moai → no change
  15. moved printer to different places in my flat → no change
  16. printed multiple objects at the same time → no change
  17. varied orientation of print → no change
  18. printed bigger model → no change, maybe worse
  19. printed known printable gcode (Known working gcode files for the Moai) → same problems
  20. Oiled Z-axis-rod with 5w30 Oil → no real change
  21. checked the galvo cover and also printed a test model without the cover → no change

If more information is needed, please ask.

0 Likes

Print Failures - Strange Artifacts and More
#2

Sorry for the double post, but I wanted to provide a picture of the test ring with the same problem.

0 Likes

#3

@Giddi

sorry about the problem you are having and the detailed summary.

It sounds like you are using everything, except one place: are you using the special power 55 Cura profile? Because for grey, it is recommended to print at 57 for most of the users.

Here is one test you can run at 100um with following changes to settings and share the picture with us:
STL
https://drive.google.com/open?id=0Bzke6lBHG_z5dllYZnhURXdJWEU

and change pm motor speed to 10. z speed to 3 (was 8)

0 Likes

#4

I have not used that profile, I will give it a try today.
Edit: I printed with laser power of 55, because I somehow got an weird batch of resin that was printable down to about 51.

But I have tested it with Black and Clear resin also, with exactly the same outcome.
I couldn’t add these pictures, because of the new user limit.

Clear: (I used a wash to make it visible) Printed at 60

0 Likes

#5

Black:

0 Likes

#6

If you measure the height of the shift from the base of the model is the shift exactly at the same height (be sure to correct for orientation)?

0 Likes

#7

@Paradoxical_Cat As far as I can tell yes, even comparing different models with different support base heights.
I’m currently printing the Test cylinder with the suggested pm an z speed settings. It may take a while for the results, because those settings are pain inducing slow.

@peopoly I ran out of grey resin so now everything posted will be in black resin. Should I still change to the 55 profile?

0 Likes

#8

no. stay in the standard profile and keep energy in 58.

0 Likes

#9

I would check the z-axis mechanism for binding. The easier way to do this is to remove the build plate and fake adjusting the z-height, which should cause the trolley to descend. Listen for sounds of mechanical interference (e.g. rubbing or binding in the travel). Repeat for the reverse direction by cycling the power, which will send the trolley to the top.

Also check the z-axis drive rod to make sure it is not wobbling or bent.

If you do not hear anything, try a pre-sliced model that is known to work, just to confirm it is not a software problem.

0 Likes

#10

@Paradoxical_Cat I already tried a presliced model (see point 19) with the same results. I will chec the z axis after the test print.

0 Likes

#11

@peopoly With the slower settings I had to raise the Laser power to 60, because the prints failed at 58. I also printed a control cylinder with the standard settings and the model from my first picture with the slow settings. On the model you can kind of see that the defects are at the same height even though they were not printed together.
The lines were fainter on both the control and slow settings cylinder. I can provide more or better pictures if needed.

@Paradoxical_Cat no real noise when the buildplate moves, but the z-axis rod wobbles slightly when the chute is moving near the Vat.

Pictures:
Left one is slow settings,
Right one is standard settings

0 Likes

#12

A couple of thoughts:

  1. Have you tried turning Zfollow off entirely?
  2. Maybe you can check the Z axis mount alignment as per @Harlequin’s suggestion: Z axis motor alignment.
  3. Finally, how well controlled is the temperature? Is the printer in an air conditioned room? Do you keep the printer door closed during the print? Both the resin and the galvos are temperature sensitive.
0 Likes

#13

Peopoly can probably comment on threaded rod movement. You could try running your fingers along the track and threaded rod to see if you feel burrs, etc. It wouldn’t take much to cause a layer shift. Alternatively, you could try using a dry lubricant on the Z axis assembly, I use a Dupont Teflon based lubricant on my FDM printers.

After that, I would look at the z-stepper. The consistency is a clue, but the lack of regularity suggests it is something else.

0 Likes

#14

I checked the z axis alignment, there was a noticeable pressure built up, but after testing it again there was no change with the prints.

I then took out the z rod with the stepper motor and closely inspected it, there were some specks of dirty that I carefully removed. After that i oiled the z-rod and installed it again.

After all this the prints are still practically the same.
Ad Temperature: I live in a 120 year old apartment building, these keep temperatures very constant. I consistenly had 27°C in the build chamber, at least for the last 3 days. I also always print with the door closed and all panels installed.

Could anybody record a video of the buildplate moving up and down, so I can see and hear what is normal and where my stuff differs? Thanks!

Edit: I didn’t feel burrs on the threaded rod

0 Likes

#15

When you had the threaded rod and motor out did you run the arm that holds the build plate up and down the Z rail to feel if there were any rough spots?

When you re-installed the motor did you have the Z arm near the bottom of the travel before tightening the screws for the motor?

Can we get a picture of the setting screens on the printer?

0 Likes

#16

I did run the z-nut up (why is it made of plastic btw?) and down to feel for resistance, but didn’t find any place where it stuck or got caught on the rod. Yes I tightened the screws after moving the z-arm to the bottom, I also tightend them in a X pattern.

here is the gcode for the little tank file I used to as a quick test (see first picture), If anyone likes to try it on their machine. https://www.dropbox.com/s/k9fetlj305y2fao/PM_test1.gcode?dl=0

Here you have pictures of the settings, I changed the laserpower back to 58 after changing back from the slow test settings.

0 Likes

#17

Did you run the arm that holds the build plate up and down the Z rail to feel if there were any rough spots without the Z screw or motor?

0 Likes

#18

I’m sorry, I have misread your question. I did now run it without the screw or the motor and indeed it isn’t really fluid in its motion, also I hear crackling when moving it, I guess that’s not normal?

If the arm or the rails are the problem, is there some way to fix that? I know from my fdm printer that the z-guides shouldn’t be oiled, is this the cas also with the Moai? Some special way to clean them?

0 Likes

#19

Is there anything that you can get a picture or video showing the rough spot? Maybe if you lower the arm and it sticks in spots or maybe a cleaning would help.

@peopoly might have some suggestions or have another solution.

0 Likes

#20

I hope this demonstrates what I mean. There isn’t really one rough spot, rather it’s not “fluid” every cm or so.

0 Likes